Opened 6 years ago

Closed 4 years ago

#4959 closed task (duplicate)

Discuss shipping and enabling tor-fw-helper by default

Reported by: karsten Owned by: ioerror
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Keywords: tor-relay flashproxy
Cc: sjmurdoch, helix Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

We have a sponsor F deliverable for either July or November 2012 to "investigate NAT piercing approaches for relays and bridges."

Jake says that, in theory, we need to ship tor-fw-helper and actually enable it. That will fix 90% of the NAT issues that we have right away. It's been merged for a year but we're still not shipping it and enabling it by default. Steven just finished the Windows port of tor-fw-helper.

Does that mean we can now ship and enable it on all platforms in the next major Tor release, which is probably going to be 0.2.4.x?

If not, what's left to do? Or is it a bad idea for some reason?

Child Tickets

Change History (12)

comment:1 Changed 6 years ago by nickm_mobile

It's in 0.2.3, so it wouldn't necessarily have to want for 0.2.4 unless there are showstopper issues. I am not convinced it's seen enough testing by users in the wild, but there's really no timeless like the present.

comment:2 in reply to:  1 Changed 6 years ago by karsten

Parent ID: #4960

Replying to nickm_mobile:

It's in 0.2.3, so it wouldn't necessarily have to want for 0.2.4 unless there are showstopper issues. I am not convinced it's seen enough testing by users in the wild, but there's really no timeless like the present.

Sounds good. I'm making this ticket a child of #4960. Having more experience with tor-fw-helper in the wild would sure be a good result for the report.

Other than that, I'm going to ignore this ticket. I only created it, because Jake asked me to. Just saying, so that nobody expects me to push this forward.

comment:3 Changed 5 years ago by ioerror

I have a draft position paper that discusses tor-fw-helper, what it is useful and not useful for doing and why we should enable it by default. Perhaps I should upload my next draft here?

comment:4 in reply to:  3 Changed 5 years ago by karsten

Replying to ioerror:

I have a draft position paper that discusses tor-fw-helper, what it is useful and not useful for doing and why we should enable it by default. Perhaps I should upload my next draft here?

Sure, please do. Or maybe it would better fit into #4960. But uploading it to either ticket sounds like a fine plan.

comment:6 Changed 5 years ago by ioerror

I've updated the latest and, I believe, final draft. It now needs to be made into an official Tor Tech Report - which likely require re-skinning of the paper without any major content changes.

comment:7 Changed 5 years ago by nickm

Keywords: tor-relay added

comment:8 Changed 5 years ago by nickm

Component: Tor RelayTor

comment:9 Changed 5 years ago by karsten

Parent ID: #4960

Removing the parent relationship in order to close the parent ticket.

comment:10 Changed 4 years ago by dcf

Keywords: flashproxy added

comment:11 Changed 4 years ago by dcf

Here is a branch that packages tor-fw-helper on top of TBB 3.5.2. (It's being used for flash proxy port forwarding, not the PortForwarding torrc option.) I sent a request to tor-qa that it be tested.

https://lists.torproject.org/pipermail/tor-qa/2014-February/000324.html
https://people.torproject.org/~dcf/pt-bundle/3.5.2-fwhelper-1/
https://gitweb.torproject.org/user/dcf/tor-browser-bundle.git/shortlog/refs/heads/tor-fw-helper

comment:12 Changed 4 years ago by dcf

Resolution: duplicate
Status: newclosed

I'm marking this as a duplicate of #5213. They seem similar enough that discussion can happen in one place.

Note: See TracTickets for help on using tickets.