Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#4973 closed defect (fixed)

Tor 0.2.3.11-alpha - absolute paths set for torrc cause failed to parse errors - Win32

Reported by: ioneyes Owned by:
Priority: Medium Milestone: Tor: 0.2.3.x-final
Component: Core Tor/Tor Version: Tor: 0.2.3.11-alpha
Severity: Keywords: win32 regression tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When setting an absolute path in vidalia's configuration GUI and starting Tor, the startup fails even though the path exists.

This was tested on Windows XP 32bit.

Child Tickets

Change History (8)

comment:1 Changed 8 years ago by arma

Please provide steps to reproduce: what path did you choose, what were the error messages, etc?

comment:2 in reply to:  1 Changed 8 years ago by ioneyes

Replying to arma:

Please provide steps to reproduce: what path did you choose, what were the error messages, etc?

With Vidalia 0.3, torrc set to c:\program files\tor\tor.torrc

The following error message occurs in vidalia:
Jan 30 23:48:57.187 [Warning] Unable to open configuration file "C:\Program Files\Tor/C:\Program Files\Tor\tor.torrc".

It looks like it is trying to prepend the current working directory of Vidalia.

The steps to reproduce the problem are

  1. ensure vidalia has valid settings and then starting it.
  2. Observing the error in the log windows for vidalia.

Let me know if you require any more information.

comment:3 Changed 8 years ago by nickm

Keywords: win32 regression added

comment:4 Changed 8 years ago by nickm

Reproducible: starting Tor with any absolute path to torrc seems to trigger this on windows.

comment:5 Changed 8 years ago by nickm

oh hey:

char *
make_path_absolute(char *fname)
{
#ifdef WINDOWS

"WINDOWS", huh?

comment:6 Changed 8 years ago by nickm

Resolution: fixed
Status: newclosed

Should be fixed in commit 48424772aa9a7b3ed4710471a205a841d69337bd ; thanks for the report!

comment:7 Changed 7 years ago by nickm

Keywords: tor-client added

comment:8 Changed 7 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.