Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#4981 closed defect (duplicate)

There is no easy way to tell tor to not use the same country per circuit

Reported by: cypherpunks Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords: tor-client
Cc: cypherpunks@…, proper@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Frequently the same country, generally Germany or the US, appears in my circuits twice. Often, first and last hop in the circuit. This seems suboptimal. There is no way to tell Tor to avoid using relays in the same country as the first and last hop. It is trivial for a single government to watch my connection as I establish it and exit within sovereign borders.

If there is a way, please tell me. thank you.

Child Tickets

Change History (3)

comment:1 Changed 7 years ago by proper

Cc: proper@… added
Resolution: duplicate
Status: newclosed

Imho this is a duplicate of #3678. There is a workaround in the end of the third comment. You are advised, not to use the workaround, as it decreases your anonymity. Therefore I conclude, that an easy feature, to activate this, won't come.

Your concern is well noted in #3678. As soon as a solution is found, Tor's routing algorithm will be updated.

comment:2 Changed 7 years ago by nickm

Keywords: tor-client added

comment:3 Changed 7 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.