Opened 7 years ago

Closed 7 years ago

Last modified 20 months ago

#5020 closed defect (fixed)

2.0dev5's option panel hangs Firefox 10 UI on Windows

Reported by: JC_Yang Owned by: pde
Priority: Immediate Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Normal Keywords: hang UI
Cc: sujitkrao@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I just update from 2.0dev4 to 2.0dev5 today.

And I soon found a critical bug.

firefox version: 10.0(final release)

OS: I've tried on 2 of my PCs, one is in XP SP3, and the other the Windows 7 x64. I have disabled all other add-ons on my Win7 machine.

Step to reproduce:

1.Open Add-ons page of firefox and go to Extensions.

2.Open the options panel of Https-Everywhere from the 'Options' button.

3.Change any setting or let it as is, click ok or simply close the Preference interface. It hang the UI of the current window of firefox completely.(If I open an new window of firefox by start from shortcut or the firefox.exe, the new window is ok, it's not affected.)

Hopefully this annoying bug can be fixed ASAP.

I will rate this bug as a blocker.

I love the back of google cache and the fixed for userscripts.org.

Thank you for your great work.

Child Tickets

Change History (11)

comment:1 Changed 7 years ago by pde

Cc: sujitkrao@… added

I can't yet reproduce this on the Linux system I have with me (although I am seeing weirdly varying heights for that prefs window, which might be something to do with this commit). I won't have access to a Windows system until Monday or Tuesday. CC'ing Sujit Rao, who worked on some UI patches that landed in the current release, in case he has any ideas.

comment:2 Changed 7 years ago by jacobske87

I can confirm this bug happens for me too. I'm on Win7 x64, with FX 10.0

comment:3 Changed 7 years ago by pde

Two diagnostic questions: (1) does this happen on FF 9 as well? (2) do you get a lockup if you click on the HTTPS Everywhere toolbar button and select "Enable / Disable rules" or "(No rules for this page)"?

comment:4 in reply to:  3 Changed 7 years ago by JC_Yang

Replying to pde:

Two diagnostic questions: (1) does this happen on FF 9 as well? (2) do you get a lockup if you click on the HTTPS Everywhere toolbar button and select "Enable / Disable rules" or "(No rules for this page)"?

I'm back to my XP SP3 machine now.
It can still be reproduced with all other add-ons disable.
Answer your two questions:
1.Haven't tried it on FF9 yet. Two much works to setup a VM here. And I don't like to rollback.
2.I won't get a lockup/hang whatever when access the panel from the toolbar buttorn and select "Enable/Disable rules".

btw, I can confirm the bug described above. That is when I first invoke the panel from Add-ons page, the size of the panel window is just like minimized. It's weird and I had to drag it's corner to enlarge it. Don't know whether this is a related bug.

comment:5 Changed 7 years ago by pde

In https://mail1.eff.org/pipermail/https-everywhere/2012-February/001272.html , Sujit Rao posted:

I can't reproduce either the hanging or the varying heights on Lion. The height problem could probably be fixed by removing the CSS and adding a call to window.resizeTo using window.screen.availHeight. I can't get to a Windows machine with Git right now to test the hanging, but I would try taking out the JS in the install.rdf, and checking how many Firefox processes there are after clicking the shortcut again.

comment:6 Changed 7 years ago by pde

Summary: Https-Everywhere 2.0dev5's option panel hang firefox 10 UI2.0dev5's option panel hangs Firefox 10 UI on Windows

comment:7 Changed 7 years ago by pde

Status: newaccepted

I finally have a Windows machine to test on today.  Sujit Rao suggested reverting the JavaScript he added to install.rdf, and that appears to work for me:

https://gitweb.torproject.org/https-everywhere.git/commitdiff/ebf1b30e829a97687ff800c1125177d8aa546be8

There are a couple of ruleset bugs to be squashed and then I'll try to push a release later today.

comment:8 in reply to:  7 Changed 7 years ago by JC_Yang

Replying to pde:

I finally have a Windows machine to test on today.  Sujit Rao suggested reverting the JavaScript he added to install.rdf, and that appears to work for me:

https://gitweb.torproject.org/https-everywhere.git/commitdiff/ebf1b30e829a97687ff800c1125177d8aa546be8

There are a couple of ruleset bugs to be squashed and then I'll try to push a release later today.

Great news! Thank you for the quick fixed. I'm looking forward the new release.

comment:9 Changed 7 years ago by JC_Yang

I can confirm the fix in dev6 work on my 2 machines.

If no further report about this crash, it should probably mark as fixed.

comment:10 Changed 7 years ago by pde

Resolution: fixed
Status: acceptedclosed

comment:11 Changed 20 months ago by teor

Severity: Normal

Set all tickets without a severity to "Normal"

Note: See TracTickets for help on using tickets.