Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5045 closed defect (not a bug)

Vidalia cannot authenticate Tor, control socket not connected

Reported by: frank21 Owned by: chiiph
Priority: Medium Milestone:
Component: Archived/Vidalia Version:
Severity: Keywords: control socket
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I use the latest Tor Bundle under XP (SP3). When starting Vidalia, I get the message: "Vidalia was unable to authenticate to Tor (control socket is not connected) Please check your port authentication settings." In the message log of Vidalia, it says "Tor software is not running". I have checked the FAQ and googled this, but nothing worked, neither changing the control port nor installing SP3 again. I have an old version of Tor, this has the same error, but it was working before. The computer is running fine, no probs with the web or anything else, device manager looks fine, no errors. The files are where they have to be (tor.exe and torrc). When starting Tor directly through the tor.exe, it connects and says circuit could have been built, the task manager shows it is running. Is this a XP error? Help is very much appreciated.

Child Tickets

Change History (8)

comment:1 Changed 8 years ago by runa

Open the Vidalia control panel, click on Settings and Advanced. What does it say under Tor Control?

comment:2 Changed 8 years ago by frank21

will have a look later today

comment:3 Changed 8 years ago by frank21

127.0.0.1 9051

PW randomely

comment:4 Changed 8 years ago by frank21

so, what be the next step?

comment:5 Changed 8 years ago by arma

See if the Vidalia message window has any hints for you.

If not, try the Tor Browser Bundle and see if it works better.

Also check if you have any other versions of Tor running.

Also, this is more of a user support question than a Vidalia bug. See the "help@rt" email address at https://www.torproject.org/about/contact.html.en#email for where this sort of thing should go.

comment:6 Changed 8 years ago by frank21

I use the Bundle, sorry for not bbeing clear.

The Vidalia message is "Tor software is not running...".

No other version available on my comp.

No Vidalia message in the advanced log.

Any idea?

comment:7 Changed 8 years ago by runa

Resolution: not a bug
Status: newclosed

Closing this as not a bug and will reply on help@….

comment:8 Changed 8 years ago by frank21

solution:

do the "cmd" and enter

netsh winsock reset

works fine now

Note: See TracTickets for help on using tickets.