Opened 8 years ago

Closed 19 months ago

#5073 closed defect (wontfix)

torbutton breaks leechblock extension

Reported by: cypherpunks Owned by: mikeperry
Priority: Low Milestone:
Component: Applications/Torbutton Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The leechblock extension < http://www.proginosko.com/leechblock.html > to Firefox allows the user block access to certain sites during certain times of the day, in order to reduce the temptation for time-wasting. It seems to interact badly with torbutton; it fails to enforce the blocking time periods correctly; blocking tends to start and end several hours early/late.

I think the problem is that leechblock relies on the javascript Date object to report the current local time correctly; AFAICT torbutton wraps this and forces it to report GMT instead. Leechblock gets additionally confused as the local time reported by the Date object changes whenever torbutton is toggled.

Is it possible for torbutton to wrap the Date object in such a way that it reports GMT as local time to javascript code running on web pages, and the correct local time to firefox extensions?

Tested using Leechblock version 0.5.2, and the versions of Firefox and Torbutton packaged with Debian squeeze (i.e. a patched Firefox 3.5.16 and Torbutton 1.2.5)

Child Tickets

Change History (2)

comment:1 Changed 2 years ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

comment:2 Changed 19 months ago by gk

Resolution: wontfix
Status: newclosed

We don't wrap the date object anymore but set the timezone to UTC. I think users that really need this extension can adapt to that.

Note: See TracTickets for help on using tickets.