Opened 8 years ago

Closed 8 years ago

#5118 closed enhancement (not a bug)

Set up bridgetester on a Tor VM

Reported by: gsathya Owned by:
Priority: Medium Milestone:
Component: Company Version:
Severity: Keywords:
Cc: phobos, weasel Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I need arma's help to set up a Tor VM for the bridge tester.

Copied from #tor-dev -

< rransom_> gsathya: How long will it take to put together *something* that can test our pile of obfsproxy bridge addresses to see whether they still work, and GPG-encrypt and mail a list of still-good addresses to someone who can use them?
< gsathya >rransom_: right now i can - 1) check if the bridges work, 2) if they are public, 3) check their bandwidth(w/ a crude implementation)
< rransom_> That sounds useful. Can you set it up on one of Tor's VMs, and have it mail a GPG-encrypted (and signed) list of still-good obfsproxy bridge addresses to armadev every day?
< gsathya> sure
< rransom_> You'll also need help with getting a VM to run the bridge tester on.
< rransom_> Assign the VM ticket to arma; he'll know what to do next.

Child Tickets

Change History (5)

comment:1 Changed 8 years ago by arma

Component: AgileCompany
Owner: arma deleted
Status: newassigned

I wonder if this wants a separate vm, or if it should run on one we have already, or what.

comment:2 Changed 8 years ago by arma

Cc: phobos weasel added

comment:3 Changed 8 years ago by runa

At this point, we do not need frequent updates of working vs not working obfsproxy bridge addresses. Until this project is more than just "test a list of IP addresses every now and then", and maintained by someone, we do not need a vm either.

comment:4 Changed 8 years ago by runa

weasel adds that we do have a shell machine for general purpose things, and I'm sure this is a fine place to run the obfsproxy bridgetester script from.

comment:5 Changed 8 years ago by weasel

Resolution: not a bug
Status: assignedclosed

Closing this ticket for now. We can always create a new one if we think we want to deploy a real bridgetester service instead of some person running it at odd intervals.

Note: See TracTickets for help on using tickets.