Opened 7 years ago

Closed 5 years ago

#5119 closed defect (not a bug)

make BridgeDB spit out a list of server-transport-proxy lines

Reported by: gsathya Owned by: aagbsn
Priority: Medium Milestone:
Component: Obfuscation/BridgeDB Version:
Severity: Keywords:
Cc: asn Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

We need BridgeDB to spit out a list of server-transport-proxy lines for distributing obfs-bridges. I currently have a bridge tester script(part of ooni) that can -1) check if the bridges work, 2) check if they are public, 3) check their bandwidth(w/ a crude implementation, probably useless for now). This can be used to help BridgeDB decide which obfs-bridges to send. I've never messed around with the BridgeDB code and I need help with that.

Copied from #tor-dev
09:49 < rransom_> The next thing to do would be to modify BridgeDB to spit out a list of all bridge descriptor lines starting with "transport-proxy ", along with the fingerprint of the bridge that provided it.
09:49 < rransom_> Hmm. Better make that "server-transport-proxy ".
09:50 < gsathya> Ok, but I'll need help with the BridgeDB code

Child Tickets

Change History (2)

comment:1 Changed 5 years ago by sysrqb

Status: newneeds_information

Is this still applicable? Do we have any docs covering the use of server-transport-proxy?

comment:2 in reply to:  1 Changed 5 years ago by gsathya

Resolution: not a bug
Status: needs_informationclosed

Replying to sysrqb:

Is this still applicable? Do we have any docs covering the use of server-transport-proxy?

I think this was during the early days of BridgeT. I'm not even sure if this is still applicable. I've mostly forgotten what this was about. I'm just going to close this.

Note: See TracTickets for help on using tickets.