Opened 7 years ago

Closed 7 years ago

#5143 closed defect (duplicate)

ServerTransportPlugin sets or_port to '127.0.0.1:0'

Reported by: murble Owned by: asn
Priority: Medium Milestone:
Component: Obfuscation/Pluggable transport Version: Tor: 0.2.3.12-alpha
Severity: Keywords: or_port
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When Tor is configured with

ORPort "[::]:9001" so on default linux it is configured
to listen on both v4 and v6 sockets.

and obfsproxy configured to run in managed mode:

ServerTransportPlugin obfs2 exec /usr/local/bin/obfsproxy --log-min-severity=debug --no-safe-logging --logfile=/var/log/tor/obfsproxy.log --managed

we get:

Proxy environment:
[...]
or_port: '127.0.0.1:0'
[...]

If we add a v4 only OrPort
OrPort "0.0.0.0:9001"
it works as expected:

[...]
or_port: '127.0.0.1:9001'
[...]

Child Tickets

Change History (1)

comment:1 Changed 7 years ago by asn

Resolution: duplicate
Status: newclosed

This is something that should be solved in #4865, I think.

I'll mark this as a duplicate of #4865, and start handling this issue there.

Thanks!

Note: See TracTickets for help on using tickets.