Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#5151 closed defect (fixed)

Bridge ignores NoAdvertise option in ORPort configurations

Reported by: karsten Owned by: ln5
Priority: Medium Milestone: Tor: 0.2.3.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-bridge
Cc: murble, nickm Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

murble found that bridges ignore the NoAdvertise option in ORPort configurations. These are the ORPort configurations of murble's bridges:

ORPort "0.0.0.0:9001"
ORPort "[::]:9001 NoAdvertise IPv6Only"
ORPort "[::]:9090 IPv6Only NoAdvertise"
ORPort "0.0.0.0:9090 NoAdvertise"
ORPort 0.0.0.0:443 NoListen

The first problem is that Tor ignores the NoAdvertise option because of this copy-paste error in config.c:

5769       cfg->no_listen = no_listen;
5770       cfg->no_listen = no_advertise;

The second problem is that Tor writes this log message on notice level:

My line is <or-address [::]:9090
>

This log message was probably meant to debug things and should go away.

So, after fixing the first problem, the bridge still wrote the "My line is ..." log message, but didn't include an "or-address" line in its descriptor. Which is somewhat strange, because the code looks like the "My line is ..." line is only written when the bridge includes the "or-address" line afterwards. More debugging necessary, but maybe this is a start.

Child Tickets

Change History (7)

comment:1 Changed 8 years ago by ln5

Status: newneeds_review

Branch bug5151 in git.tpo/linus/tor.git fixes the NoAdvertise issue.

I was not able to reproduce the reported problem that "My line is ..."
was logged even with working NoAdvertise.

bug5151 also fixes the issue with "My line is ..." being logged at
notice level.

comment:2 Changed 8 years ago by nickm

Milestone: Tor: 0.2.3.x-final

comment:3 Changed 8 years ago by nickm

Status: needs_reviewneeds_revision

Looks good; I assumed you tested it? Also, it needs a changes file.

comment:4 Changed 8 years ago by ln5

I did test it.

changes file added.

comment:5 Changed 8 years ago by nickm

Resolution: fixed
Status: needs_revisionclosed

Merged; thanks!

comment:6 Changed 7 years ago by nickm

Keywords: tor-bridge added

comment:7 Changed 7 years ago by nickm

Component: Tor BridgeTor
Note: See TracTickets for help on using tickets.