Opened 8 years ago

Closed 8 years ago

#5157 closed enhancement (fixed)

obfsproxy --version should exist

Reported by: arma Owned by: asn
Priority: Medium Milestone:
Component: Archived/Obfsproxy Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

It would be good if it told me the git version it built from, also.

And put the version in the "Starting" line in the log.

Child Tickets

TicketTypeStatusOwnerSummary
#5560defectclosedasn'obfsproxy --version' is buggy

Change History (5)

comment:1 Changed 8 years ago by asn

Status: newneeds_review

Please see bug5157 in https://git.gitorious.org/obfsproxy/obfsproxy.git.

comment:2 Changed 8 years ago by Sebastian

This ticket also asked for --version, which isn't provided here. Otherwise, this looks good.

comment:3 Changed 8 years ago by asn

Oops! Done! Thanks!

comment:4 Changed 8 years ago by asn

I'm thinking of merging this in 48-hours, if I don't get any shouts against the idea. The branch doesn't seem very destructive.

comment:5 Changed 8 years ago by asn

Resolution: fixed
Status: needs_reviewclosed

Merged.

Note: See TracTickets for help on using tickets.