Opened 7 years ago

Closed 7 years ago

Last modified 20 months ago

#5173 closed defect (duplicate)

`extern char **environ;` is not always harmless

Reported by: rransom Owned by:
Priority: Immediate Milestone: Tor: 0.2.3.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

SwissTorExit reports a compile error on Kubuntu 11.10 amd64, with GCC 4.6.1:

compat.c:1667:15: erreur: redundant redeclaration of ‘environ’ [-Werror=redundant-decls]
/usr/include/unistd.h:542:15: note: previous declaration of ‘environ’ was here
cc1: all warnings being treated as errors

Apparently extern char **environ; isn't always harmless.

Child Tickets

Change History (4)

comment:1 Changed 7 years ago by Sebastian

Resolution: duplicate
Status: newclosed

Dupe of #5161

comment:2 Changed 7 years ago by nickm

Keywords: tor-client added

comment:3 Changed 7 years ago by nickm

Component: Tor ClientTor

comment:4 Changed 20 months ago by teor

Severity: Normal

Set all tickets without a severity to "Normal"

Note: See TracTickets for help on using tickets.