Opened 6 years ago

Closed 5 years ago

#5193 closed enhancement (implemented)

Tor Browser Bundle Shows No Socks Proxy Connection Info

Reported by: DasFox Owned by: mikeperry
Priority: Medium Milestone:
Component: Firefox Patch Issues Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm running Linux, so I'm not sure if this is the same for the other versions of the browser bundle, but if it is I hope someone can please correct this.

This is not a bug, rather a lack of a feature that seems fairly important.

In The network settings and using a proxy to access the internet, I noticed when using a Socks 5 proxy there is no information being listed in the Message Log, about the connectivity to this proxy.

I think it would be great if Tor showed some type of connectivity information, showing it was making the connection, when the connection is completed and successful, then making the connections to Tor, rather then simply connecting and getting online.

I reported something like this in the past, but it seemed like Tor was just by passing the proxy and getting online and without any information in the log, we don't really know if it was successful or Tor simply by passed it and was able to get online, also there could be a bug in the software, so we need some type of logging information...

THANKS

Child Tickets

Change History (2)

comment:1 Changed 6 years ago by mikeperry

Milestone: TorBrowserBundle 2.3.x-stable
Priority: majornormal
Type: defectenhancement

comment:2 Changed 5 years ago by mikeperry

Resolution: implemented
Status: newclosed

Duplicate of #6009 (I guess? I mean we already do tell you you're connected like 4 different ways... But let's try a few different ways why not).

Note: See TracTickets for help on using tickets.