Opened 2 years ago

Closed 2 years ago

#5214 closed defect (fixed)

QT-Problem on openSUSE 11.4

Reported by: Schweineschwarte Owned by: erinn
Priority: normal Milestone:
Component: Tor bundles/installation Version: Tor: 0.2.2.35
Keywords: Cc:
Actual Points: Parent ID:
Points:

Description

Hello,

my system:

  • openSUSE 11.4
  • x86_64
  • KDE 4.6

Since the version 'tor-browser-gnu-linux-x86_64-2.2.35-5-dev-de', my
tor-browser-bundle doesn't start. The Errormessage:

combo@linux:~/Downloads/tor-browser_de> sh start-tor-browser

Launching Tor Browser Bundle for Linux in
/home/combo/Downloads/tor-browser_de
Cannot mix incompatible Qt library (version 0x40701) with this library
(version 0x40704)
start-tor-browser: Zeile 205: 24118 Abgebrochen
./App/vidalia --datadir Data/Vidalia/
Vidalia exited abnormally. Exit code: 134

Up to version 'tor-browser-gnu-linux-x86_64-2.2.35-4-dev-de' I had no
problems.
A friend, which has a 32bit-system and uses openSUSE 11.4 too, have the
same problem.

QT-Versions:

rpm -qa | grep libqt
libqt4-4.7.1-8.15.1.x86_64
libqt4-sql-sqlite-32bit-4.7.1-8.15.1.x86_64
libqt4-sql-4.7.1-8.15.1.x86_64
libqt4-sql-mysql-32bit-4.7.1-8.15.1.x86_64
libqt4-x11-32bit-4.7.1-8.15.1.x86_64
libqt4-sql-mysql-4.7.1-8.15.1.x86_64
libqt4-sql-sqlite-4.7.1-8.15.1.x86_64
libqt4-x11-4.7.1-8.15.1.x86_64
libqt4-devel-4.7.1-8.15.1.x86_64
libqt4-32bit-4.7.1-8.15.1.x86_64
libqt4-qt3support-4.7.1-8.15.1.x86_64
libqt4-sql-32bit-4.7.1-8.15.1.x86_64
libqt4-qt3support-32bit-4.7.1-8.15.1.x86_64

Child Tickets

Change History (5)

comment:1 Changed 2 years ago by Sebastian

  • Component changed from - Select a component to Tor bundles/installation
  • Owner set to erinn

Looks like that's caused by updating Qt to 4.7.4. What we'll have to figure out is why your system is favoring 4.7.1 libs over the stuff we bundle

comment:2 Changed 2 years ago by Sebastian

I think I have this figured out. KDE 4 on opensuse seems to cause the Qt stuff to want more Qt libs, so we need to ship some more. Don't have a definite list yet, but I think libQtDBUS is what we have to add...

comment:3 Changed 2 years ago by Sebastian

  • Status changed from new to needs_review

Hah, even better, we can just tell Qt not to use that silly KDE 4 look and it'll all work, unless a user actually selects the Oxygen style from within Vidalia. Chiiph suggested that nice workaround. Vidalia will still crash if people manually pick the Oxygen style, but for now we should just tell them not to do that.

Schweineschwarte: If you want to test the fix, just edit the file start-tor-browser, find the line that reads (pretty much at the bottom of the file):

./App/vidalia --datadir Data/Vidalia/

and replace it with

./App/vidalia --datadir Data/Vidalia/ -style Cleanlooks

comment:4 Changed 2 years ago by Schweineschwarte

@Sebastian
Yes with these workaround works. =)
Thank you!

comment:5 Changed 2 years ago by Sebastian

  • Resolution set to fixed
  • Status changed from needs_review to closed

this got merged, should be fixed

Note: See TracTickets for help on using tickets.