Opened 8 years ago

Closed 8 years ago

#5217 closed defect (not a bug)

Obfsproxy Tor Browser no longer works in China

Reported by: hrimfaxi Owned by: asn
Priority: Medium Milestone:
Component: Archived/Obfsproxy Version: Tor: 0.2.3.12-alpha
Severity: Keywords: GFW China obfsproxy
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

a few days ago I got Obfsproxy Tor Browser https://www.torproject.org/projects/obfsproxy. It worked fine at first. But today I found out it no longer works.

Here is my log:
二月 23 20:06:45.179 [Notice] Tor v0.2.3.12-alpha (git-ff0059b924ec9bf1) running on Windows 7 Service Pack 1 [workstation].
二月 23 20:06:45.180 [Notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
二月 23 20:06:45.180 [Notice] This version is not a stable Tor release. Expect more bugs than usual.
二月 23 20:06:45.180 [Notice] Read configuration file "C:\temp\Tor Browser\Data\Tor\torrc".
二月 23 20:06:45.289 [Notice] Initialized libevent version 2.0.16-stable using method win32. Good.
二月 23 20:06:45.289 [Notice] Opening Socks listener on 127.0.0.1:9050
二月 23 20:06:45.289 [Notice] Opening Control listener on 127.0.0.1:9051
二月 23 20:06:45.289 [Notice] Parsing GEOIP file .\Data\Tor\geoip.
二月 23 20:06:45.397 [Notice] No AES engine found; using AES_* functions.
二月 23 20:06:45.397 [Notice] This OpenSSL has a good implementation of counter mode; using it.
二月 23 20:06:48.509 [Notice] Heartbeat: Tor's uptime is 0:00 hours, with 0 circuits open. I've sent 0 kB and received 0 kB.
二月 23 20:06:50.542 [Notice] Bootstrapped 5%: Connecting to directory server.
二月 23 20:06:50.572 [Notice] Bootstrapped 10%: Finishing handshake with directory server.
二月 23 20:06:51.358 [Warning] Problem bootstrapping. Stuck at 10%: Finishing handshake with directory server. (DONE; DONE; count 10; recommendation warn)
二月 23 20:06:51.358 [Warning] 12 connections have failed:
二月 23 20:06:51.358 [Warning] 10 connections died in state handshaking (TLS) with SSL state SSLv2/v3 read server hello A in HANDSHAKE
二月 23 20:06:51.359 [Warning] 2 connections died in state handshaking (proxy) with SSL state (No SSL object)

I didn't have a private obfs2 bridge at hand. So I cannot tell if it was because GFW staffs got the Obfsproxy Tor Browser as well and banned all its bridges in its configure. But it's possible because there are few obfs2 bridge in public.

Child Tickets

Change History (3)

comment:1 Changed 8 years ago by rransom

Component: - Select a componentObfsproxy
Owner: set to asn

comment:2 Changed 8 years ago by asn

Hi hrimfaxi,

is there a way to send you some private obfs2 bridge addresses for you to try?
IRC, email, or anything would be fine

comment:3 Changed 8 years ago by runa

Resolution: not a bug
Status: newclosed

hrimfaxi: I will email you a few obfsproxy bridge addresses now. In the future, please email help@… for things like that (bugs etc can still go on trac).

Note: See TracTickets for help on using tickets.