Opened 8 years ago

Closed 5 years ago

#5227 closed defect (fixed)

Can't run Tor from unpriv acct on Mac OS X

Reported by: blank_stare Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: needs-triage
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

From Lion (OS X 10.7.3), I installed Tor recently, and it runs fine from my privileged account. However, each time I try to start Tor from my unprivileged account, it fails with the following message in a "pop-up" window:

Vidalia can't find out how to talk to Tor because it can't access this file: ../../Contents/Resources/Data/Tor/port.conf
Here's the last error message:
Permission denied

In the message log (Advanced), the following appears:

Feb 25 04:32:08.908 [Notice] Tor v0.2.2.35 (git-b04388f9e7546a9f). This is experimental software. Do not rely on it for strong anonymity. (Running on Darwin x86_64)
Feb 25 04:32:08.909 [Warning] Could not open "../../Library/Vidalia/torrc": Permission denied
Feb 25 04:32:08.909 [Warning] Unable to open configuration file "../../Library/Vidalia/torrc".
Feb 25 04:32:08.910 [Error] Reading config failed--see warnings above.

I see that a similar bug description has been filed at least once previously, but was dropped due to lack of information. I need to use Tor, and will gladly support resolving this in whatever way I can.

Danke!

Child Tickets

Change History (6)

comment:1 Changed 8 years ago by Sebastian

Is that the Tor Browser Bundle? Or the Vidalia Bundle? How did you install it, and where to? Also, if you fetch a Tor Browser Bundle in your limited account and extract and use it, does it work?

comment:2 Changed 7 years ago by andrea

Component: - Select a componentVidalia
Owner: set to chiiph

comment:3 Changed 7 years ago by arma

I don't think this is a Vidalia bug. It's likely a duplicate of one of the "if you put Tor Browser Bundle in a directory you can't read/write to, it will fail in a confusing way" tickets.

The fix in this case is to unzip Tor Browser Bundle using the account that you plan to run it from.

comment:4 Changed 7 years ago by nickm

Component: VidaliaTor bundles/installation
Owner: changed from chiiph to erinn

comment:5 Changed 5 years ago by erinn

Keywords: needs-triage added

comment:6 Changed 5 years ago by erinn

Resolution: fixed
Status: newclosed

Closing since I don't think this is a problem anymore; please reopen if it is.

Note: See TracTickets for help on using tickets.