Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5228 closed defect (invalid)

reading log severity levels

Reported by: eliaz Owned by: chiiph
Priority: Medium Milestone: TorBrowserBundle 2.3.x-stable
Component: Archived/Vidalia Version: Vidalia: 0.2.17
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I asked this in tor-talk, and it was suggested I open a ticket. I'm running a normal bridge on Vistax64 in TBB ver -.7.1. The problem: When I write "log warn stdout" into the torrc file, I don't see any warn or err lines in the Advanced tab of the Message Log, but only info lines. I do see warning msgs on the Basic tab, e.g.,

[Sat Feb 25 05:23:46 2012] Potentially Dangerous Connection! - One of your applications established a connection through Tor to "198.252.153.56:995" using a protocol that may leak information about your destination. Please ensure you configure your applications to use only SOCKS4a or SOCKS5 with remote hostname resolution.

I'm not here concerned about that particular msg; I believe my browser is correctly configured. My question: Are warn and err msgs meant to appear only on the Basic view, not in Advanced, or is this a bug? thanks - eliaz

Child Tickets

Change History (3)

comment:1 Changed 8 years ago by Sebastian

Resolution: invalid
Status: newclosed

This isn't a bug here, you'd want to actually use Vidalia to configure logging, not modify the torrc directly. Vidalia doesn't use tor's stdout to pass on logs as soon as other methods are available, afaik.

comment:2 Changed 8 years ago by eliaz

you'd want to actually use Vidalia to configure logging

I do "write the log warn" in using Vidalia, sorry for my imprecision. Still am not clear on why the logs as they update don't show only the warns & errs only, but I'll stop worrying about it as long as its not a bug. Thanks for your help.

comment:3 Changed 8 years ago by Sebastian

When you are in the message log window in Vidalia, do you click Settings, then remove the checkboxes for everything except warning, clicke save settings, and get any non-warning messages still shown? If yes, then this is a bug. If no, then you're doing something that won't affect Vidalia's message logging.

Note: See TracTickets for help on using tickets.