Opened 8 years ago

Closed 6 years ago

#5261 closed defect (fixed)

TBB for Linux tries to talk to an X session manager

Reported by: rransom Owned by: erinn
Priority: High Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: easy
Cc: chiiph, mikeperry, ioerror, g.koppen@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

People have been seeing this ‘error’ message for a long time:

Qt: Session management error: None of the authentication protocols specified are supported

The error is harmless, but the fact that it is occurring means that TBB-Vidalia is trying to connect to a session manager. That isn't so harmless.

It would be very bad if any part of TBB actually succeeded in talking to an X session manager. Can TBB-Vidalia ever connect to a session manager? Can TBB-Firefox ever connect to a session manager?

Child Tickets

Attachments (1)

resolve-5261.patch (879 bytes) - added by peer 7 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 8 years ago by gk

Cc: g.koppen@… added

comment:2 Changed 7 years ago by rransom

#5465 is a duplicate of this bug; see that ticket for how to fix the problem.

comment:3 Changed 7 years ago by mikeperry

Keywords: easy added

comment:4 Changed 7 years ago by peer

Status: newneeds_review

patch added

comment:5 in reply to:  4 Changed 7 years ago by rransom

Status: needs_reviewneeds_revision

Replying to peer:

patch added

Please specify a hostname in your author e-mail address (“127.0.0.1” should be sufficient to avoid breaking the crap programs that refuse to work unless something that looks like a hostname is present there).

It would be bad if zenity talked to an X session manager, too. Unset the variable earlier in the script, before any GUI programs might be started.

comment:6 Changed 7 years ago by peer

Status: needs_revisionneeds_review

Thank you for the comments. Patch revised.

comment:7 Changed 7 years ago by arma

Erinn, it looks like this would be a fine thing to merge into the 0.2.4 TBB series, since it's small, "what could go wrong", etc.

comment:8 Changed 7 years ago by erinn

I'd like to merge this. peer, do you want to get credit for this patch? If so, can you make a new one with a better commit message and possibly a real email address? Otherwise I will be happy to make one myself and credit you appropriately. We will likely release some new alpha bundles this week and I would like to get this fix in with them, so please let me know in the next two days or so. Thank you for the patch!

comment:9 in reply to:  8 Changed 7 years ago by arma

Replying to erinn:

If so, can you make a new one with a better commit message

In particular, something that explains what the problem is, and why this is the fix. Pretend you don't have trac nearby when you're reading through the git commit log.

Changed 7 years ago by peer

Attachment: resolve-5261.patch added

comment:10 Changed 7 years ago by peer

No special requests regarding credit. Thanks!

The patch's commit message has been revised and the commit is also available at https://bitbucket.org/peer_zero/torbrowser/commits/74c8604ab0a8cd97b4628f40b1ec7237549ad476 . Which would be preferred?

comment:12 Changed 6 years ago by mikeperry

Resolution: fixed
Status: needs_reviewclosed

This seems to have been merged already in 3.0. Not sure when.

Note: See TracTickets for help on using tickets.