Opened 8 years ago

Closed 6 years ago

#5272 closed enhancement (not a bug)

BridgeT: Check if bridges are public relays

Reported by: gsathya Owned by: isis
Priority: Medium Milestone:
Component: Archived/Ooni Version:
Severity: Keywords: bridge reachability
Cc: gsathya, isis@… Actual Points:
Parent ID: #6414 Points:
Reviewer: Sponsor:

Description

Thus, spoke arma -
< armadev> gsathya: feature request: when your ooni learns the bridge descriptor behind an obfsproxy, check if it's a public relay and warn if so.

Basically, queries onionoo to see if the bridge is public.
https://github.com/gsathya/ooni-probe/commit/f26af2d6d67f94c09586dd8b9360f294a5bdc55d

Child Tickets

Change History (10)

comment:1 Changed 8 years ago by Sebastian

Summary: BridgeT: Check if bridges are publicBridgeT: Check if bridges are public relays

comment:2 Changed 8 years ago by gsathya

Status: newneeds_review

Query onionoo through Tor - All requests are done through Tor now. Also, Onionoo URL is now a global variable.

https://github.com/gsathya/ooni-probe/commit/59e3e0e3ced2ce85f1799ea36ed0bd77abb04401

comment:3 Changed 8 years ago by hellais

Resolution: fixed
Status: needs_reviewclosed

Thanks. Merged. Maybe we should make this optional though, as it will drastically reduce performance of bridge scanning.

comment:4 in reply to:  3 Changed 8 years ago by gsathya

Replying to hellais:

Thanks. Merged. Maybe we should make this optional though, as it will drastically reduce performance of bridge scanning.

That was quick! Thanks! Optional sounds fine, but I doubt this reduces performances as much as the bandwidth testing?

comment:5 Changed 8 years ago by karsten

Resolution: fixed
Status: closedreopened

Wait, you're transmitting all bridge fingerprints via HTTP GET requests to my personal VM. Please don't do that.

A better approach would be to download the list of currently running relays when BridgeT starts and compare locally. If you want, you can update that list every, say, 5--15 minutes, though not for every bridge scan.

Also note the onionoo.torproject.org URL in that link. Please put that in instead of the IP address, so that we can move the service in the future without breaking BridgeT.

comment:6 in reply to:  5 Changed 8 years ago by hellais

Type: defectenhancement

Replying to karsten:

Wait, you're transmitting all bridge fingerprints via HTTP GET requests to my personal VM. Please don't do that.

A better approach would be to download the list of currently running relays when BridgeT starts and compare locally. If you want, you can update that list every, say, 5--15 minutes, though not for every bridge scan.

Also note the onionoo.torproject.org URL in that link. Please put that in instead of the IP address, so that we can move the service in the future without breaking BridgeT.

This sounds reasonable. For the time being I have commented out in BridgeT the lines that do the check for bridge publicness in commit bd383663eff8703e0a78704703dbfba4dba46992.

If we want this feature it should be integrated as karsten suggested.

comment:7 Changed 7 years ago by isis

Cc: isis@… added
Keywords: bridge reachability added
Owner: changed from hellais to isis
Parent ID: #6414
Status: reopenedassigned

I'm adding this as a feature to the new bridge reachability tests.

comment:8 Changed 7 years ago by isis

Status: assignedneeds_revision

This was reimplemented here, though the bridge tests are currently blocking on incompatibility with OONI's API change.

comment:9 in reply to:  8 Changed 7 years ago by hellais

Replying to isis:

This was reimplemented here, though the bridge tests are currently blocking on incompatibility with OONI's API change.

What exactly is the issue?

The part of code you mention there is not being called anywhere. If you ping me on IRC I can help you get it to work.

Also you may want to take a look at the comments I made here: https://gitweb.torproject.org/ooni-probe.git/blob/6a3ee55b574adaa8740ccafe2e4a01719dc0e86e:/ooni/utils/onion.py.

Most of the functions you have implemented there are already part of txtorcon, so I think it's not a good idea to have such amount of code duplication.

comment:10 Changed 6 years ago by hellais

Resolution: not a bug
Status: needs_revisionclosed

This ticket is no longer relevant, therefore I am going to close it.

Note: See TracTickets for help on using tickets.