Opened 8 years ago

Closed 7 years ago

#5285 closed defect (implemented)

smartlist_isin should be named smartlist_contains

Reported by: rransom Owned by:
Priority: Medium Milestone: Tor: 0.2.4.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:


Child Tickets

Change History (9)

comment:1 Changed 8 years ago by nickm

Sensible. Presumably then smartlist_{string,digest,string_num}_isin{_case,} should be renamed smartlist_contains_{string,digest,int_as_string}{_case,}.

I'd take an automatically generated patch with accompanying script.

comment:2 Changed 8 years ago by nickm

Status: newneeds_review

Please review branch "rename5285" in my public repository?

(I'd defer this to 0.2.4, but getting renames done before the forks means less pain later.)

comment:3 Changed 8 years ago by nickm

Milestone: Tor: 0.2.3.x-finalTor: 0.2.4.x-final

Actually, we have enough to do. Let's delay this to late in 0.2.4.x; it is good to do, but won't hurt anything to wait

comment:4 Changed 8 years ago by andrea

This looks just fine to me. I still feel like too much of a n00b to do the merges, though, so I'll just comment here and let you.

comment:5 Changed 8 years ago by nickm

okay. I'll let this languish till later in the 0.2.4.x cycle, so that we don't have as many volatile changes going on in 0.2.3.x to merge forward and conflict here.

comment:6 Changed 8 years ago by arma

I think we're done with volatile changes going on in 0.2.3, fwiw.

comment:7 Changed 8 years ago by nickm

Keywords: tor-client added

comment:8 Changed 8 years ago by nickm

Component: Tor ClientTor

comment:9 Changed 7 years ago by nickm

Resolution: implemented
Status: needs_reviewclosed

Okay, now it's "Later in the 0.2.4.x cycle". Recreating and merging as "bug5285_v2"

Note: See TracTickets for help on using tickets.