Opened 8 years ago

Closed 7 years ago

#5302 closed defect (fixed)

Google search by image broken

Reported by: cypherpunks Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

www.google.com/searchbyimage?image_url=https://trac.torproject.org/images/tor-logo.png redirects back to the main site of Google instead of showing results for the image.

Child Tickets

Change History (9)

comment:1 Changed 8 years ago by pde

Status: newaccepted

This seems to be fixed in git and the forthcoming 3.0development.1 release, but I will leave this open until we can merge a fix in 2.0 stable.

comment:2 Changed 8 years ago by pde

The plot thickens.  I can sometimes reproduce this, and sometimes not.  Might be a proper Heisenbug...

comment:3 Changed 8 years ago by pde

Right now it's working for me in multiple profiles, but five minutes ago it wasn't.  Maybe someone changed something on the server side? :)

Let's try to keep testing this for a while before declaring victory.

comment:4 Changed 8 years ago by cypherpunks

It doesn't work for me in 2.0.2, it still redirects to https://encrypted.google.com/webhp?[...] as it did in 2.0.1.

comment:5 Changed 8 years ago by pde

I've asked someone at Google to take a look at this.  We'll see what happens.

comment:6 Changed 8 years ago by cypherpunks

Are you sure the rule is merged in the stable version? If I understand https://gitweb.torproject.org/https-everywhere.git/blobdiff/a2f118d85f92e32bf1d08189963479ad8cbecde7:/src/chrome/content/rules/GoogleWWW.xml..6ad1eb9443f4eb1013407c1c7118635c3c7da153:/src/chrome/content/rules/GoogleMainSearch.xml correctly, typing "www.google.com" in the URL bar should take me to https://www.google.com. It takes me to https://encrypted.google.com instead. If I type "https://www.google.com" then it goes straight to https://www.google.com, so it's not a matter of HTTPS Google refusing to serve Tor or your extension. I'm using the latest TBB with HTTPS-Everywhere 2.0.2.

comment:7 Changed 8 years ago by pde

Somewhat OT for this bug, but that ruleset (GoogleMainSearch.xml) is off by default.  If you want to use it, click on the HTTPS Everywhere toolbar button and select "Search www.google.com".

comment:8 Changed 8 years ago by pde

(I guess not totally OT).  The one that most users have operating is this:

https://gitweb.torproject.org/https-everywhere.git/blob/6ad1eb9443f4eb1013407c1c7118635c3c7da153:/src/chrome/content/rules/GoogleSearch.xml

For undocumented alphabetical reasons, if they're both enabled, I believe GoogleMainSearch should apply first.

comment:9 Changed 7 years ago by pde

Resolution: fixed
Status: acceptedclosed

This seems to be fixed now.

Note: See TracTickets for help on using tickets.