Opened 8 years ago

Closed 8 years ago

#5322 closed defect (not a bug)

doesn't obey user.js? setting custom proxy settings

Reported by: cypherpunks Owned by: mikeperry
Priority: Medium Milestone:
Component: TorBrowserButton Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm not sure if this is a bug or just misconfiguration:

https://trac.torproject.org/projects/tor/wiki/doc/TorBOX/Dev/ClientVM#IcantfigureouthowtopreconfigureTBBtousesocksport9100

I set socks proxy to a non-default value. Either it ignores that and uses 9050 or it sets and empty values. In this case, behind a transparent proxy TBB will continue to work but show that scary red X icon.

Setting cusom proxy through gui works, changing the IP from localhost works. It's only the Port that is showing these problems.

Child Tickets

Change History (1)

comment:1 Changed 8 years ago by mikeperry

Resolution: not a bug
Status: newclosed

You need the Torbutton proxy settings to be in sync with the browser proxy settings, otherwise Torbutton thinks it is disabled.

Set the proxy port you want in the Torbutton preferences under the "Use Custom Proxy Settings" radiobutton, and then examine the changes to the prefs.js in the TBB Firefox profile dir.

Note: See TracTickets for help on using tickets.