Opened 8 years ago

Closed 4 years ago

#5330 closed defect (user disappeared)

closing tbb firefox brings up a dialog that does odd things

Reported by: phobos Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When closing FF in TBB, vidalia pops up a dialog that gives me three choices: 'reopen the browser', 'close tor', 'do nothing'. If I choose 'reopen the browser', firefox takes 40-80 seconds to start up.

If I choose 'close tor', sometimes tor closes, sometimes vidalia and tor restart, but firefox doesn't start. If I start torbrowser via "~/path/to/tor-browser_en-US/start-tor-browser' tor closes. If I start torbrowser via '~/path/to/tor-browser_en-US/start-tor-browser &', tor and vidalia restart and pop up again.

'do nothing' consistently does nothing, as expected.

Child Tickets

Change History (7)

comment:1 Changed 8 years ago by chiiph

I can't reproduce this with Ubuntu 11.10.

The 40-80 seconds start up, yeah, I don't know how are we going to work that out, but that's a different bug.

When you say "vidalia and tor restarts", you mean that the app closes and opens again? Or that tor gets stopped and suddenly it's starting again? The odd things is this weird restart, or am I missing something?

comment:2 in reply to:  1 Changed 8 years ago by sirop

Replying to chiiph:

When you say "vidalia and tor restarts", you mean that the app closes and opens again? Or that tor gets stopped and suddenly it's starting again? The odd things is this weird restart, or am I missing something?

I saw this weird restarting with tor-browser_en-US-2.2.35-6-dev and vidalia-0.3.1.
But I could not reproduce the bug with tor-browser-2.2.35-7.2-dev and vidalia-0.3.1.

Not a Vidalia bug at all?

comment:3 Changed 8 years ago by chiiph

Component: VidaliaTor Browser
Owner: changed from chiiph to mikeperry

This is not a Vidalia bug, I've just bumped into this issue with Linux. It seems that if you start TBB with --debug, it will re launch Vidalia afterwards.

...

if [ "${debug}" ]; then
        printf "\nStarting Vidalia now\n"
        cd "${HOME}"
        printf "\nLaunching Vidalia from: `pwd`\n"
        # XXX Someday we should pass whatever command-line arguments we got
        # (probably filenames or URLs) to Firefox.
        ./App/vidalia --loglevel debug --logfile vidalia-debug-log \
        --datadir Data/Vidalia/
        printf "\nVidalia exited with the following return code: $?\n"
fi

# not in debug mode, run proceed normally
printf "\nLaunching Tor Browser Bundle for Linux in ${HOME}\n"
cd "${HOME}"
# XXX Someday we should pass whatever command-line arguments we got
# (probably filenames or URLs) to Firefox.
./App/vidalia --datadir Data/Vidalia/

...

comment:4 Changed 8 years ago by mikeperry

Component: Firefox Patch IssuesTor bundles/installation
Owner: changed from mikeperry to erinn
Version: Vidalia: 0.3.1-alpha

comment:5 Changed 8 years ago by Sebastian

That bug was supposed to be fixed. WHich version exactly are you seeing it with? The thing you copy/pasted above is not from the latest version!

comment:6 Changed 8 years ago by erinn

Status: newneeds_information

comment:7 Changed 4 years ago by cypherpunks

Resolution: user disappeared
Status: needs_informationclosed

3 years since questions was asked, no answer. No Vidalia (which used to brings up a dialog that does odd things) used anymore.

Note: See TracTickets for help on using tickets.