Opened 8 years ago

Closed 8 years ago

#5360 closed defect (duplicate)

Duplicate tray icon in Vidalia 0.3.1 on KDE 4

Reported by: haviah Owned by: chiiph
Priority: Low Milestone:
Component: Archived/Vidalia Version: Vidalia: 0.3.1-alpha
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Precise version specification: alpha version of Vidalia 0.3.1 from alpha TBB tor-browser-gnu-linux-x86_64-2.3.12-alpha-1-en-US.tar.gz

When TBB is executed via start-tor-browser, two tray icons are displayed (see attachment).

Does not occur when Vidalia is launched solo like this (in tor-browser_en-US directory):

LD_LIBRARY_PATH=Lib App/vidalia

The following reproduces the tray icon bug:

LD_LIBRARY_PATH=Lib App/vidalia --datadir Data/Vidalia/

A wild guess is that it has something to do with the popup "Remember: please wait..."

OS: Scientific Linux 6.2 x86_64 running KDE 4.3.4

Child Tickets

Attachments (1)

vidalia-multi-icon.png (2.4 KB) - added by haviah 8 years ago.
Multiple tray icons in vidalia 0.3.1

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by haviah

Attachment: vidalia-multi-icon.png added

Multiple tray icons in vidalia 0.3.1

comment:1 Changed 8 years ago by haviah

Confirmed: it's due to the popup call in ./Data/Vidalia/plugins/tbb/tbb.js.

If body of showWaitDialog() is commented out, everything is fine.

comment:2 Changed 8 years ago by chiiph

Resolution: duplicate
Status: newclosed

This a duplicate of #5338.

Note: See TracTickets for help on using tickets.