Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#5363 closed defect (invalid)

Hidden Services randomly stop working

Reported by: torbug Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.2.35
Severity: Keywords: tor-hs
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I am hosting a few hidden services on my server with Tor.
Recently I started having a problem where one of the hidden services randomly stops working, nobody can connect to it (circuit timeout error).

It seems Tor is still broadcasting the hidden service descriptor (otherwise it would say "hidden service unavailable, try again later") but nobody is actually able to make a connection.

There is no problem with my network and the Tor process is still running.
In some cases I have many hidden services in the torrc but maybe only one of them is unreachable.
There is nothing in the Tor log (one went down on 10th march, but last entry in Tor log was 8th march).

Sending the HUP signal to tor to reload does not fix the problem.
If I close Tor and restart it, then the hidden service starts working again.

This is a very frustrating problem, because it is difficult to know if a service is down without manually checking them as there is nothing in logs and I usually don't check them every day.
Some of the services get alot of traffic and some of them don't, so its difficult for me to notice if one of the small services go down.

Sorry I didn't give much technical info and this is basically "it doesn't work" type bug but I dont know what more info to give.
Is there something I can do to narrow down where the problem is, something like traceroute for tor would be useful to find out where the connection is failing.

Thank you I really appreciate what the Tor Project is doing.

Child Tickets

Change History (9)

comment:1 Changed 8 years ago by rransom

Try upgrading the Tor client which hosts the hidden services to Tor 0.2.3.12-alpha. This could be a case of #3825.

comment:2 Changed 7 years ago by torbug

OK I tried Tor 0.2.3.12-alpha (on client and server) but after 8 days the problem happened again so its not fixed in the alpha.

This time it gave a different error message in the client, but still same problem, hidden service suddenly stops responding to all requests requiring a restart of Tor.

Mar 19 03:30:44.790 [Notice] Closing stream for '[scrubbed].onion': hidden service is unavailable (try again later).

comment:3 Changed 7 years ago by rransom

How many hidden services are you running using the server's Tor instance? (If you use ‘HiddenServiceAuthorizeClient stealth’, count each user as a separate hidden service.)

Do you have a ‘RendPostPeriod’ line in your torrc? If so, what is its value? (Please don't add this option if you don't have it set already.)

comment:4 Changed 7 years ago by torbug

I had one Tor instance with 5 hidden services.
It also happened on a Tor instance that had only 2 services, and another that had 1.
Each time only 1 of the configured hidden services had this problem, the rest of them worked fine.

I do not have a HiddenServiceAuthorizeClient or RendPostPeriod line in torrc.

The only changes I have made to the torrc are...

HardwareAccel 1
AccelName aesni
NumCPUs 12
LearnCircuitBuildTimeout 0
CircuitBuildTimeout 5

comment:5 in reply to:  4 Changed 7 years ago by rransom

Resolution: invalid
Status: newclosed

Replying to torbug:

LearnCircuitBuildTimeout 0
CircuitBuildTimeout 5

Remove these lines. 5 seconds is way too short for a non-adaptive CBT.

Please reopen this ticket if your hidden services still stop working. (Closing as ‘invalid’, because there is no better ‘resolution’ for user error.)

comment:6 Changed 7 years ago by rransom

(I opened #5452 for ‘Tor should have fussed about its CBT’.)

comment:7 Changed 7 years ago by arma

I wonder what documentation told the submitter to set those lines.

comment:8 Changed 7 years ago by nickm

Keywords: tor-hs added

comment:9 Changed 7 years ago by nickm

Component: Tor Hidden ServicesTor
Note: See TracTickets for help on using tickets.