Opened 5 years ago

Closed 5 years ago

#5417 closed defect (fixed)

RelativeLink.sh in Tor browser bundle has small typo causing debug mode to be always turned on

Reported by: cypherpunks Owned by: erinn
Priority: Very High Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: Sebastian, erinn Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

TBB starts in debug mode disregardless of --debug switch used or not. This is caused by small bug on line 208 on RelativeLink.sh, where it says

if [ "${debug}" ];

where it should say

if [ "${debug}" == 1];

or

if [ ${debug} -eq 1 ];

Child Tickets

Change History (4)

comment:1 Changed 5 years ago by rransom

Use:

if [ "$debug" -eq 1 ]; then

The == test is not supported by POSIX test(1). Make sure there is a space between 1 and ].

comment:2 Changed 5 years ago by mikeperry

Cc: Sebastian erinn added
Component: Tor BrowserTor bundles/installation
Owner: changed from mikeperry to erinn
Priority: normalcritical

comment:3 Changed 5 years ago by erinn

Mike,

I don't think it was a problem with any merges. I merged rransom's bug4093b branch, but looking at it, and through other relevant branches, I think that line was just overlooked. Fixing it now.

comment:4 Changed 5 years ago by erinn

Resolution: fixed
Status: newclosed

Fixed in the latest Linux TBBs. Closing.

Note: See TracTickets for help on using tickets.