Opened 8 years ago

Closed 3 years ago

#5423 closed defect (worksforme)

No Characters Showing Up On 'Check Page'

Reported by: DasFox Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-fingerprinting-fonts
Cc: Actual Points:
Parent ID: #18097 Points:
Reviewer: Sponsor:

Description

This isn't a bug I'm reporting unless it could be one, when I start the Tor Browser bundle in Linux; 2.2.35-9 I noticed on the Check Page, some foreign languages are not showing up, I just get boxes instead.

Please see this attached image and if someone can please tell me what languages/fonts I need for those, I'll check...

THANKS

Child Tickets

Attachments (2)

tor-browser_en-US-2.2.35-9.png (46.0 KB) - added by DasFox 8 years ago.
tor_browser.png (48.1 KB) - added by DasFox 8 years ago.

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by DasFox

comment:1 Changed 8 years ago by arma

Component: Tor BrowserTor bundles/installation
Owner: changed from mikeperry to erinn

How does http://www.baidu.com/ look for you?

Are you using the 64-bit tbb or the 32-bit tbb in linux?

What linux distro?

comment:2 Changed 8 years ago by rransom

Component: Tor bundles/installationTor Browser
Status: newneeds_information

The characters which failed to render in that screenshot are Chinese ideograms and Japanese kanji.

This is a ‘Tor Browser’ bug, not a ‘Tor bundles/installation’ bug, and it may be a duplicate of #4797.

Did those characters appear correctly in previous versions of TBB?

comment:3 Changed 8 years ago by rransom

On my Debian Wheezy system, the ‘CJK Unified Ideographs’ Unicode block is provided by the font ‘WenQuanYi Zen Hei’.

Changed 8 years ago by DasFox

Attachment: tor_browser.png added

comment:4 Changed 8 years ago by DasFox

I'm using the 32bit TBB...

Ok I installed the wqy-zenhei-font, I didn't have this installed before and now it looks like it's working ok, please look at the screen shot I'm attaching to confirm...

This is showing for Japanese and Chinese, I don't get why I wouldn't need the sazanami-fonts-ttf for the Japanese characters to show up, even though I understand some of this is borrowed from Chinese, but still.... Hmmm

comment:5 Changed 4 years ago by bugzilla

Component: Firefox Patch IssuesTor Browser
Keywords: tbb-fingerprinting-fonts added
Severity: Normal

comment:6 Changed 3 years ago by cypherpunks

Owner: changed from erinn to tbb-team
Parent ID: #18097
Status: needs_informationassigned

comment:7 Changed 3 years ago by gk

Resolution: worksforme
Status: assignedclosed

Our site has changed since then and the language dropdown menu does not show the same issues. Thus, closing as WORKSFORME.

Note: See TracTickets for help on using tickets.