Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5429 closed task (wontfix)

Please add runa@tpo to planet.tpo cron job

Reported by: runa Owned by: phobos
Priority: Medium Milestone:
Component: Webpages/Website Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The cron job for planet.tpo will email tor-assistants@tpo when something's wrong (and the emails will bounce, and Sebastian will forward them to runa@tpo). Please add runa@tpo to the cron, or find some other solution?

Child Tickets

Change History (9)

comment:1 Changed 8 years ago by phobos

Resolution: not a bug
Status: newclosed

There are no errors to view, thus nothing to forward. Once in a while, a feed doesn't update. No big deal, it'll try again in an hour.

comment:2 Changed 8 years ago by Sebastian

Resolution: not a bug
Status: closedreopened

The point is that each time a feed doesn't update I get to emails that I have to check for problems. So it would be good if the cron job didn't cause two emails in a common error case.

comment:3 Changed 8 years ago by phobos

technically they go to torproject-admin, so I get them too.

comment:4 Changed 8 years ago by phobos

I watched this for the past week. Every error is a timeout error when pulling a feed. I'm aware of the emails. In every case, it resolved itself at the next schedule pull.

comment:5 Changed 8 years ago by runa

Resolution: fixed
Status: reopenedclosed

Ok, I guess phobos will take care of planet.tpo if the cron fails for some reason other than a normal timeout.

comment:6 Changed 8 years ago by Sebastian

Another 28 emails in the past day...

comment:7 Changed 8 years ago by phobos

Resolution: fixed
Status: closedreopened

Indeed. I took out the feed causing the problems. Frankly, planet shouldn't be emailing anything, ever. I'm tempted to shutdown the whole planet site. It needs a curator to find relevant content and maintain it, not just pull from some RSS feeds that have interesting tags in it. The current feed (as of 08:04 GMT-4) shows 'Philippines: Students Prevented from Graduating Over Facebook Bikini Photos', 'Supreme Court, in 5-4 decision, OK strip searches for minor offenses', 'A bullet killed Ahmed Ismael, but not his videos'.

The first relevant item to Tor isn't until seven articles into the page.

Another question is why torwww is set to email tor-assistants instead of torproject-admins.

comment:8 Changed 8 years ago by phobos

Resolution: wontfix
Status: reopenedclosed

closing since the original request is closed. and removing the PI website solved the endless email problem due to timeouts.

comment:9 in reply to:  7 Changed 8 years ago by runa

Replying to phobos:

I'm tempted to shutdown the whole planet site. It needs a curator to find relevant content and maintain it, not just pull from some RSS feeds that have interesting tags in it.

I agree. Setting up planet.tpo was something we apparently promised some sponsor that we'd do, but no one really wanted to set it up or maintain it. We should avoid these types of projects in the future.

Note: See TracTickets for help on using tickets.