Opened 8 years ago

Closed 7 years ago

#5431 closed defect (not a bug)

Fix google captcha detection

Reported by: mikeperry Owned by: mikeperry
Priority: High Milestone:
Component: TorBrowserButton Version:
Severity: Keywords:
Cc: schoen Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

03:17 < schoen> mikeperry: Google added HTTPS support for sorry.google.com
03:18 < schoen> mikeperry: I think this might be a result of a private conversation I had an a Google

SSL engineer (!)

03:18 < schoen> tragic because several people from Tor and EFF were asking about this repeatedly

through various channels for over a year

03:18 < schoen> anyway...
03:19 < schoen> mikeperry: I believe the relevant rule is in the development branch but not in stable
03:19 < schoen> but I would recommend manually putting it in the next browser bundle, and then you can

kill the special case in Tor Browser that detects Google captchas

Child Tickets

Change History (1)

comment:1 Changed 7 years ago by mikeperry

Cc: schoen added
Resolution: not a bug
Status: newclosed

Turns out that the https support for "sorry" (while awesome from a privacy perspective for protection of query strings) neither breaks our captcha redirect, nor stops captchas from happening.

I think that this is not a bug for Tor then. Please reopen otherwise.

(#4666 is our best hope at a solution to really solve the captcha problem.)

Note: See TracTickets for help on using tickets.