Opened 7 years ago

Closed 7 years ago

Last modified 3 years ago

#5433 closed defect (not a bug)

Tor Browser Bundle 32bit Linux - GTK2 Themes Not Sticking

Reported by: DasFox Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

TBB 32bit for Linux 2.2.35-9 is having GTK2 problems with Vidalia. In the Appearance settings it won't keep a theme on GTK when I restart, it always goes back to the default look/color of Viadalia and I have to keep switching it to GTK.

This is the only version I've seen this problem and it only happens in Vidalia, Firefox renders the theme every time it starts...

What's odd is if I keep restarting Viadalia, sometimes it renders some of the theme, by that I mean, the background might be the color of the theme, but the connection bar that moves from left to right showing the progress as an example will have the default color and this never seems to change.

Also when Firefox has started, then I noticed Vidalia at that point changed the theme, which seems odd it won't stay in the settings but something to do with Firefox running changes it...

Child Tickets

Change History (7)

comment:1 Changed 7 years ago by DasFox

Forgot to mention, but hopefully someone understood when I said; 'I have to keep switching it to GTK'. The Appearance settings keep reverting back to 'Clearlooks'...

THANKS

comment:2 Changed 7 years ago by rransom

Resolution: not a bug
Status: newclosed

Vidalia uses Qt, and Vidalia in TBB is configured to use the Clearlooks theme because loading a system-wide Qt theme may crash it. (Different versions of Qt libraries do not mix well.)

comment:3 Changed 7 years ago by rransom

(This feature was introduced in order to fix #5214.)

comment:4 Changed 7 years ago by rransom

You might also be seeing #3865 here -- does it work if you wait until Firefox has started?

comment:5 Changed 7 years ago by Sebastian

Nah, that wouldn't be it, the TBB start script overwrite the style via option switch

comment:6 Changed 7 years ago by DasFox

It does change after firefox starts but this is the first version that has done this, so I know this is not correct...

QTconfig has GTK in it, so that means when starting a QT app that has GTK in the settings it should run it with a GTK theme and it's been doing it like this for me in the past...

THANKS

comment:7 Changed 3 years ago by michael926@…

Severity: Normal
Note: See TracTickets for help on using tickets.