Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#5450 closed task (duplicate)

Remove Tor's SHA-256 implementation

Reported by: rransom Owned by:
Priority: Low Milestone: Tor: 0.2.4.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tor includes an implementation of SHA-256 (in src/common/sha256.c) in case it is linked to a version of OpenSSL older than 0.9.8. Tor should no longer support such old versions of OpenSSL, so Tor should dump code needed only to support them.

Some changes to src/common/crypto.c will also be needed (at a minimum, in crypto_hmac_sha256).

Child Tickets

Change History (3)

comment:1 Changed 7 years ago by rransom

Resolution: duplicate
Status: newclosed

Duplicate of #6825.

comment:2 Changed 7 years ago by nickm

Keywords: tor-client added

comment:3 Changed 7 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.