Opened 8 years ago

Closed 8 years ago

#5465 closed defect (duplicate)

Unset SESSION_MANAGER env var in TBB-Linux RelativeLink.sh

Reported by: rransom Owned by: erinn
Priority: High Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

On startup, Vidalia often complains that it could not authenticate to the user's X session manager:

Qt: Session management error: None of the authentication protocols specified are supported

Vidalia should not be attempting to connect to a session manager, and the fact that it does could leave traces on disk outside the TBB directory.

It appears that Vidalia/Qt attempts to connect to a session manager iff the SESSION_MANAGER environment variable is set. RelativeLink.sh should unset that variable.

(Hopefully unsetting that variable will also keep Firefox from trying to talk to a session manager.)

It appears that Vidalia/Qt will be unable to connect to the session manager even if it attempts to, because the user's $HOME/.ICEauthority file is not present in the TBB directory. The GNOME 2 session manager did not log a message in $HOME/.xsession-errors when Vidalia failed to connect to it; hopefully other session managers won't log authentication errors either, but we shouldn't count on that.

Child Tickets

Change History (1)

comment:1 Changed 8 years ago by rransom

Resolution: duplicate
Status: newclosed

Duplicate of #5261.

Note: See TracTickets for help on using tickets.