Opened 7 years ago

Last modified 8 weeks ago

#5556 assigned enhancement

magnet uri support

Reported by: cypherpunks Owned by:
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-firefox-patch
Cc: mikeperry Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I couldn't figure out how to configure magnet uri's. The browser does ask for permission to open the associated application but it never sends the uri. One might also want to configure.

Other things like ed2k:// or retroshare:// links might also be interesting to have.

Child Tickets

Change History (12)

comment:1 Changed 7 years ago by rransom

Resolution: invalid
Status: newclosed

comment:2 Changed 7 years ago by runa

Milestone: Tor: very long term
Priority: trivialnormal
Resolution: invalid
Status: closedreopened
Type: defectenhancement

A number of users are asking about how they can get the Tor Browser to recognize magnet links. This is about how you can download torrent files with the Tor Browser and have them open in your favorite torrent client, not about downloading torrents over Tor.

comment:3 Changed 7 years ago by rransom

For a ‘magnet link’, right-click the link, click ‘Copy Link Location’, and paste the URL into the torrent client. For a torrent file (not the same as a magnet link), save the file with ‘Save Link As...’ and open it with the torrent client.

It would probably be very bad if TBB supported the ‘magnet:’ URI scheme directly.

comment:4 Changed 6 years ago by mikeperry

Resolution: not a bug
Status: reopenedclosed

Ask Mozilla for this.

comment:5 Changed 6 years ago by Phreak

Resolution: not a bug
Status: closedreopened

This is supported in Firefox, this does not work in Tor.

Simply put, this is not a Mozilla issue, nor is it a Firefox issue, this is a Tor Browser issue.

As per the original description: When clicking magnet:// prefixed links, "The browser does ask for permission to open the associated application. The associated application never recieves the message from the TBB. This works in normal Firefox.

comment:6 in reply to:  5 ; Changed 6 years ago by bastik

Replying to Phreak:

[...] The associated application never recieves the message from the TBB. This works in normal Firefox.

If I click on a link in TorBrowser and it opens some external application, which is not configured to use Tor I'm leaking. This sounds unsafe to me. I might be expecting such behavior, but what about some dude, that downloaded a torrent client, which is configured to work in the background?

comment:7 in reply to:  6 Changed 6 years ago by aj

Replying to bastik:

If I click on a link in TorBrowser and it opens some external application, which is not configured to use Tor I'm leaking. This sounds unsafe to me. I might be expecting such behavior, but what about some dude, that downloaded a torrent client, which is configured to work in the background?

Surely a reasonable compromise is simply to caveat the permission request dialog with the appropriate warnings like the many other useful TorBrowser warnings?

It seems much less reasonable that the 'click' goes nowhere - it's not even explicitly denied or declined in any way. Personally my first thought was that my computer had some problem with it's application 'bindings' as it felt like TorBrowser had handed off the request.

comment:8 Changed 5 years ago by erinn

Keywords: tbb-firefox-patch added

comment:9 Changed 5 years ago by erinn

Component: Firefox Patch IssuesTor Browser

comment:10 Changed 21 months ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

comment:11 Changed 19 months ago by V@…

As a work around simply go to about:config and create new boolean preference
network.protocol-handler.external.magnet

set it to true.

comment:12 Changed 8 weeks ago by gaba

Cc: mikeperry added
Owner: mikeperry deleted
Status: reopenedassigned
Note: See TracTickets for help on using tickets.