Opened 8 years ago

Closed 5 years ago

#5581 closed defect (fixed)

TBB build script doesn't know where to find non-latest libpng tarball

Reported by: jamesbrown Owned by: erinn
Priority: Medium Milestone: TorBrowserBundle 2.2.x-stable
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: needs-triage
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When I try to build TBB from sources for Maemo 5 I have the next result:
[sbox-FREMANTLE_X86: ~/tor-browser-2.2.35-8-src/build-scripts] > make -f linux.mk build-all-binaries
/scratchbox/tools/bin/wget --no-check-certificate --directory-prefix=/srv/build-trees/build-alpha ftp://ftp.simplesystems.org/pub/libpng/png/src/libpng-1.5.9.tar.bz2
--2012-04-06 18:10:31-- ftp://ftp.simplesystems.org/pub/libpng/png/src/libpng-1.5.9.tar.bz2

=> `/srv/build-trees/build-alpha/libpng-1.5.9.tar.bz2'

Resolving ftp.simplesystems.org (ftp.simplesystems.org)... 65.66.246.92
Connecting to ftp.simplesystems.org (ftp.simplesystems.org)|65.66.246.92|:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done. ==> PWD ... done.
==> TYPE I ... done. ==> CWD (1) /pub/libpng/png/src ... done.
==> SIZE libpng-1.5.9.tar.bz2 ... done.
==> PASV ... done. ==> RETR libpng-1.5.9.tar.bz2 ...
No such file `libpng-1.5.9.tar.bz2'.

make: * srv/build-trees/build-alpha/libpng-1.5.9.tar.bz2 Error 8

wget --no-check-certificate --directory-prefix=/srv/build-trees/build-alpha ftp://ftp.simplesystems.org/pub/libpng/png/src/libpng-1.5.9.tar.bz2 has as result the same error.

Child Tickets

Change History (7)

comment:1 Changed 8 years ago by Sebastian

The problem is that libpng upgraded and removed the download. We should, if possible, find a place that hosts all libpng releases, not just the latest version, and use that location. If we can't, upgrading to 1.5.10 will be the bandaid we need here.

comment:2 Changed 7 years ago by mikeperry

Component: TorBrowserButtonTor bundles/installation
Keywords: TBB buld-scripts removed
Owner: changed from mikeperry to erinn

comment:3 Changed 7 years ago by Sebastian

The bandaid was applied. Still looking for a proper fix :/

comment:4 Changed 7 years ago by arma

Summary: TBB bulid script for Linux errorTBB build script for Linux error

comment:5 Changed 7 years ago by arma

Priority: majornormal
Summary: TBB build script for Linux errorTBB build script doesn't know where to find non-latest libpng tarball

comment:6 Changed 5 years ago by erinn

Keywords: needs-triage added

comment:7 Changed 5 years ago by erinn

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.