Opened 12 years ago

Last modified 7 years ago

#568 closed defect (Won't fix)

panther dislikes tor r12801

Reported by: phobos Owned by:
Priority: Low Milestone:
Component: Core Tor/Tor Version: 0.2.0.9-alpha
Severity: Keywords:
Cc: phobos, nickm Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

panther can't even configure tor anymore:
/autogen.sh
configure.in:23: error: possibly undefined macro: AS_HELP_STRING

If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.

CONFDIR=/Library/Tor ./configure --prefix=/Library/Tor --bindir=/Library/Tor --sysconfdir=/Library
configure: error: cannot find install-sh or install.sh in . ./.. ./../..

[Automatically added by flyspray2trac: Operating System: OSX 10.3 Panther]

Child Tickets

Change History (8)

comment:1 Changed 12 years ago by nickm

What's the last revision that seemed to build ok on panther?

comment:2 Changed 12 years ago by phobos

0.2.0.9-alpha. The rlim_t fixes for leopard seem to have broken panther. 0.2.0.12-alpha at least completes
autogen.sh without errors. This allows configure to run.

comment:3 Changed 12 years ago by phobos

See #553 for rlim_t issues. This error during autogen.sh is new.

comment:4 Changed 12 years ago by nickm

If you run "make dist" on a non-panther platform, and then build from the tarball, does this error still happen?

comment:5 Changed 12 years ago by phobos

autogen in 0.1.2.18 works.

comment:6 Changed 12 years ago by nickm

Okay, so it looks like this is a matter of having a new autoconf. Calling this "won't fix", since panther
users can build from tarballs, OR upgrade their autoconf.

comment:7 Changed 12 years ago by nickm

flyspray2trac: bug closed.

comment:8 Changed 7 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.