Opened 7 years ago

Closed 7 years ago

#5697 closed defect (fixed)

MacOS Torbrowser crashing on nyt and news.google.com

Reported by: mwolfe Owned by: Sebastian
Priority: Very High Milestone:
Component: Firefox Patch Issues Version:
Severity: Keywords:
Cc: Sebastian, erinn, g.koppen@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I tried several times to read the New York Times, but each time Torbrowser crashed.

I am running Mac OSX 10.6.8 and TorBrowser-2.2.35-9.1-osx-x86_64-en-US

Child Tickets

Attachments (2)

TorCrash.rtf (61.2 KB) - added by mwolfe 7 years ago.
TorBrowser_crash.txt (38.9 KB) - added by runa 7 years ago.

Download all attachments as: .zip

Change History (13)

Changed 7 years ago by mwolfe

Attachment: TorCrash.rtf added

comment:1 Changed 7 years ago by mikeperry

Cc: Sebastian erinn added
Component: TorBrowserButtonFirefox Patch Issues
Priority: normalcritical
Summary: Torbrowser crashingTorbrowser crashing on nyt and news.google
Version: Tor: 0.2.2.35

Yeah, I'm working to get to the bottom of this. It is related to one of our patches.

comment:2 Changed 7 years ago by mikeperry

Summary: Torbrowser crashing on nyt and news.googleMacOS Torbrowser crashing on nyt and news.google.com

It's also specific to MacOS afaik. At least Linux is not affected. Have not heard anything from the windows users either.

comment:3 Changed 7 years ago by mikeperry

Owner: changed from mikeperry to Sebastian
Status: newassigned

Sebastian/erinn: There is still too much magic sauce in our build process for me to reproduce this. The Mac OS Firefox builds I create (using the mozconfig Sebastian emailed me) do not have the crash bug in them, even with full patches applied.

You guys are going to have to just binary search the patches themselves. Start with all of them, verify crash. Then cut that set in half, verify crash. If no crash, check other half. Repeat subdivision until only one patch remains. Tell me that patch.

You don't have to build full TBBs for this. I am able to reproduce this simply by launching our Torbrowser.app in a vanilla Firefox profile. (Remember to set torbrowser.version to some random string in that profile).

comment:4 Changed 7 years ago by mikeperry

Note: Don't forget to try the null set (no patches) before you subdivide. This could actually be due to the magic sauce itself.

comment:5 Changed 7 years ago by gk

Cc: g.koppen@… added

comment:6 Changed 7 years ago by runa

Resolution: duplicate
Status: assignedclosed
Summary: MacOS Torbrowser crashing on nyt and news.google.comMacOS Torbrowser crashing on sites with images

Latest reports from users indicate that TBB crashes whenever the user visits a site with images (new.google.com, nyt, duckduckgo). Attached is another crash log (OS X 10.6.8).

Changed 7 years ago by runa

Attachment: TorBrowser_crash.txt added

comment:7 Changed 7 years ago by Sebastian

Resolution: duplicate
Status: closedreopened

Why is this closed? What is this a duplicate of?

Mike: FF crashes without any patches applied.

comment:8 in reply to:  7 Changed 7 years ago by runa

Replying to Sebastian:

Why is this closed? What is this a duplicate of?

I pressed the wrong button, probably. This is not a duplicate, I just wanted to update the summary and add the crash log.

comment:9 in reply to:  7 Changed 7 years ago by mikeperry

Summary: MacOS Torbrowser crashing on sites with imagesMacOS Torbrowser crashing on nyt and news.google.com

Replying to Sebastian:

Mike: FF crashes without any patches applied.

Sounds fun. There must be a bug in the build tools you are using that is not present in mine.

Are you able to build in a fresh VM with a fresh copy of Xcode and yasm? I built with Xcode 3 on OS 10.6 32bit and yasm 1.2.0.

Runa: It's definitely not any image that will crash it. I can browse to some sites with images just fine. Sites with jpegs work for sure, which I think rules out jpegturbo+yasm. I am changing the title back to nyt+news.google.com until we find out what image type actually causes the crash (if it is even images at all).

comment:10 Changed 7 years ago by Sebastian

It's building with llvm-gcc on 10.7, which causes the bug. Building with clang fixes it. Patch is in branch maint-2.2, waiting to be merged

comment:11 Changed 7 years ago by erinn

Resolution: fixed
Status: reopenedclosed

We believe this is fixed in the new bundles. Please update to 2.2.35-10. I'm going to close this, but reopen it if you experience the same problem.

Note: See TracTickets for help on using tickets.