Opened 7 years ago

Closed 5 years ago

#5698 closed defect (fixed)

The Help->'About Torbrowser' window is Firefox-specific and uses Mozilla logos and links

Reported by: phobos Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-branding, tbb-helpdesk-frequent, TorBrowserTeam201502R, GeorgKoppen201502R
Cc: tagnaq@…, davidD, arthuredelstein Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

  1. The Firefox logo should be replaced by the Tor Browser logo.
  2. The large word Firefox should be replaced with TorBrowser.
  3. The text is wrong. Perhaps 'The TorBrowser is designed by The Tor

Project, based upon the Firefox browser, to keep you in control of your
privacy and anonymity online.'

  1. The link to 'tor project' should link to https://www.torproject.org/.
  2. 'Get Involved?' should link to

https://www.torproject.org/getinvolved/volunteer.html.en.

  1. The 'Licensing Information' text and link should be replaced with

'Questions?' which points to https://www.torproject.org/docs/faq.html.en.

  1. The 'End User Rights' text and link should be replaced with 'Help

Tor Grow!' which points to https://www.torproject.org/getinvolved/relays.

  1. The 'Privacy Policy' text and link needs to be removed.
  2. The light grey text at the bottom about the Mozilla/Firefox trademarks

should be replaced with '"Tor" and the "Onion Logo" are registered
trademarks of The Tor Project, Inc.'

Child Tickets

Change History (23)

comment:1 Changed 7 years ago by h8a14i20QH

I'd like to add that the version number displayed should be that of the bundle as a whole, instead of the current version of Firefox. So, for the current version: "2.2.35-10", followed by platform and architecture where appropriate, instead of "12". At the moment a "Get Info…" in OS X on the bundle as a whole reveals the version as "1.0", which is terribly uninformative. "About…" for Vidalia reveals the version as 2.2.35, so the architecture (in my case, 64-bit Intel) and "-10" are missing.

So, as it stands, it doesn't appear to be possible for a user to query the current version of their TorBrowserBundle. Seeing as TorBrowser is probably the aspect that most users are going to interact with most, it makes sense to make the current version of the bundle available in its "About" window.

comment:2 in reply to:  1 Changed 7 years ago by rransom

Replying to h8a14i20QH:

So, as it stands, it doesn't appear to be possible for a user to query the current version of their TorBrowserBundle.

A released TBB's version should be shown in the first line of Docs/changelog inside every bundle. That's where the Tor Short User Manual tells users to look for the version number (to defend themselves against version-rollback attacks; see also #2340).

You can also find the TBB version in [about:config], as the value of ‘torbrowser.version’. See also #5194.

comment:3 Changed 7 years ago by tagnaq

Cc: tagnaq@… added

comment:4 Changed 6 years ago by cypherpunks

This ticket might be invalid now as there isn't an "about:torbrowser" page in Tor Browser 3.5.

There is a nice "about:tor" page with tpo links, the TBB version, and no Firefox branding.

However, the "about:" page is still full of Firefox branding. I filed #10888 about that.

comment:5 Changed 6 years ago by gk

Keywords: tbb-branding added

comment:6 Changed 5 years ago by mikeperry

Keywords: tbb-helpdesk-frequent added

comment:7 Changed 5 years ago by mikeperry

Summary: The 'about torbrowser' window is confusing.The Help->'About Torbrowser' window is Firefox-specific and uses Mozilla logos and links

comment:8 Changed 5 years ago by arma

(Sysrqb just closed #11313 as a duplicate of this one)

comment:9 Changed 5 years ago by cypherpunks

Is it "Tor Browser Bundle", "TorBrowserBundle", "Tor Browser", "TorBrowser", or "Torbrowser"?

comment:10 Changed 5 years ago by erinn

Keywords: needs-triage added

comment:11 Changed 5 years ago by erinn

Component: Tor bundles/installationTor Browser
Owner: changed from erinn to tbb-team

comment:12 Changed 5 years ago by mcs

(I closed #12845 as a duplicate of this issue)

comment:13 Changed 5 years ago by gk

Cc: davidD added

#13820 is a duplicate.

comment:14 Changed 5 years ago by arthuredelstein

Cc: arthuredelstein added

comment:15 Changed 5 years ago by gk

Keywords: needs-triage removed

comment:16 Changed 5 years ago by arthuredelstein

Keywords: TorBrowser201502R added
Status: newneeds_review
Last edited 5 years ago by arthuredelstein (previous) (diff)

comment:17 Changed 5 years ago by mikeperry

Keywords: TorBrowserTeam201502R added; TorBrowser201502R removed

comment:18 Changed 5 years ago by gk

Keywords: GeorgKoppen201502R added

comment:19 Changed 5 years ago by gk

Here are my comments:

-I think we should use a different logo, ideally the one we already use in other places (see tor-browser/browser/branding/official/default*.png) and which is more related to the one we have on the website (https://www.torproject.org/projects/torbrowser.html.en).

-I wonder if we should use the same size as Mozilla does (192x192 IIRC) and how this would look like.

-The version text currently says something like "31.4.0Tor Browser tbb-nightly (based on Mozilla Firefox 31.4.0)". I think it should be "tbb-nightly (based on Mozilla Firefox 31.4.0)".

-The Mozilla Firefox Licensing link is confusing. Users might be irritated as they don't have a Firefox but a Tor Browser. Especially as about:license says things like: "Binaries of this product have been made available to you by the Mozilla Project".
what we should do, I think, is change the link text to "Tor Browser Licensing" and then we might think about removing/adapting the first two paragraphs in about:license + adding Tor Browser related licensing and leave the rest as-is.

Apart from the things above the changes look good to me.

comment:20 in reply to:  19 ; Changed 5 years ago by arthuredelstein

Replying to gk:

Here are my comments:

Thanks for the review! I'll work on fixing all the issues you raise.

-I think we should use a different logo, ideally the one we already use in other places (see tor-browser/browser/branding/official/default*.png) and which is more related to the one we have on the website (https://www.torproject.org/projects/torbrowser.html.en).

I can switch to this logo for now, although it might be worth discussing the logo situation, as we have several different logos (globes, onions, etc) appearing in different places on the Tor website and in the Tor Browser package and because of the heterogeneity, I don't think they are serving the usual purpose of logos, which is to be quickly recognizable. <bikeshed> The onion I used is, I think, the most unique and visually appealing version of the several onions Tor (Browser) uses. </bikeshed>

comment:21 in reply to:  20 Changed 5 years ago by gk

Replying to arthuredelstein:

Replying to gk:

Here are my comments:

Thanks for the review! I'll work on fixing all the issues you raise.

-I think we should use a different logo, ideally the one we already use in other places (see tor-browser/browser/branding/official/default*.png) and which is more related to the one we have on the website (https://www.torproject.org/projects/torbrowser.html.en).

I can switch to this logo for now, although it might be worth discussing the logo situation, as we have several different logos (globes, onions, etc) appearing in different places on the Tor website and in the Tor Browser package and because of the heterogeneity, I don't think they are serving the usual purpose of logos, which is to be quickly recognizable. <bikeshed> The onion I used is, I think, the most unique and visually appealing version of the several onions Tor (Browser) uses. </bikeshed>

Yes, I agree. I think having a new bug proposing to change/discuss that is the right way to go, though, as it is more or less orthogonal and might require more thought and input from other teams (legal, press...). Avoiding to grow the Tor Browser logo zoo further seemed to be a good starting point for me for now (first use just one logo, if possible, then discuss switching it in all places of relevance).

comment:22 in reply to:  19 Changed 5 years ago by arthuredelstein

Replying to gk:

Here are new versions of both patches:
https://github.com/arthuredelstein/torbutton/commit/7fd169e56e60ff70254c2d60600fab88a03246da
https://github.com/arthuredelstein/tor-browser/commit/9e728a9670a066c87e9e1afe4ab3a14fbdfbdee9

-I think we should use a different logo, ideally the one we already use in other places (see tor-browser/browser/branding/official/default*.png) and which is more related to the one we have on the website (https://www.torproject.org/projects/torbrowser.html.en).

Logo has been changed to default*.png

-I wonder if we should use the same size as Mozilla does (192x192 IIRC) and how this would look like.

I ended up using 180 x 180, which seems to roughly match the Firefox logo in apparent size at 192 x 192.

-The version text currently says something like "31.4.0Tor Browser tbb-nightly (based on Mozilla Firefox 31.4.0)". I think it should be "tbb-nightly (based on Mozilla Firefox 31.4.0)".

I think I've fixed it. It requires the tor-browser.git patch to work.

-The Mozilla Firefox Licensing link is confusing. Users might be irritated as they don't have a Firefox but a Tor Browser. Especially as about:license says things like: "Binaries of this product have been made available to you by the Mozilla Project".
what we should do, I think, is change the link text to "Tor Browser Licensing" and then we might think about removing/adapting the first two paragraphs in about:license + adding Tor Browser related licensing and leave the rest as-is.

Makes sense. I've updated the link to have the text "Licensing Information" (same text as Mozilla Firefox), and added a ticket to fix about:license in the future (#14936).

comment:23 Changed 5 years ago by gk

Resolution: fixed
Status: needs_reviewclosed

Ok. This is fixed in Torbutton commit 7fd169e56e60ff70254c2d60600fab88a03246da and Tor Browser commits 552bdedc60ddac8a7dba54363442bbfc282a94b5 and 25646ee4fcc9e6b910a1441616d744089a57dac5. The latter is a small fixup that keeps the line length below 80 chars (a thing I forgot to mention in my review). Another thing I forgot is that "based on" needs to get somehow localized, too, as the whole about dialog gets localized. This is #14941.

Note: See TracTickets for help on using tickets.