Opened 8 years ago

Closed 8 years ago

#5718 closed defect (fixed)

obfsproxy, pkg-config as a hard dependency

Reported by: asn Owned by: asn
Priority: Medium Milestone:
Component: Archived/Obfsproxy Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: #5672 Points:
Reviewer: Sponsor:

Description

#5672 made pkg-config a hard dependency for building obfsproxy. This seems to be a bad idea, since pkg-config is quite hard to build and install in Windows because of a circular dependency with glib [0].

Furthermore, obfsproxy can be installed even without pkg-config by using the _LIBS and _CFLAGS environment variables.

This ticket is about reversing #5672 or finding a better solution (if there is one.).

[0]: http://www.mingw.org/wiki/FAQ or google for "pkg-config windows"

Child Tickets

Change History (2)

comment:1 Changed 8 years ago by asn

Status: newneeds_review

Please see branch bug5718 in https://git.gitorious.org/obfsproxy/obfsproxy.git.

comment:2 Changed 8 years ago by asn

Resolution: fixed
Status: needs_reviewclosed

Merged.

Note: See TracTickets for help on using tickets.