Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#5726 closed enhancement (not a bug)

Sheevaplug Review

Reported by: cypherpunks Owned by:
Priority: Very Low Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

my mail to tor-relays didn't reach the list (send via mixmaster)
so I copy it here (I suppose non-subscribers are not allowed)
Feel free to send a link to tor-relays pointing to this entry.

---

Hi,

I would like to share my experience running a Sheevaplug (Debian)
as a middle relay at a home Internet uplink with a maximal
upload bandwidth of 4 Mbps.

The Sheevaplug was dedicated to run Tor only,
so the system load and traffic you see on the following
graphs was exclusively generated by Tor.

http://imageshack.us/f/190/dailytrafficrxtxtotal.png/
http://imageshack.us/f/338/trafficday.png/
http://imageshack.us/f/838/connectionsweek.png/
http://imageshack.us/f/443/ppsday.png/
http://imageshack.us/f/824/memoryday.png/
http://imageshack.us/f/208/cpuday.png/
http://imageshack.us/f/269/loadday.png/

Occasionally the log showed the following warning:
"[warn] Your computer is too slow to handle this many circuit creation requests!
Please consider using the MaxAdvertisedBandwidth config option or choosing a more restricted exit policy."

but otherwise it seamed to run fast enough to handle 4 Mbps of Tor traffic coming in and going out.

The Sheevaplug seams to have a heat problem when running 24/7 with
steady load. My Sheevaplug unfortunately died (power supply).
Many other report the same problem:
http://chemicaloliver.net/electronics/sheevaplug-why-globalscale-suck/
http://plugcomputer.org/plugforum/index.php?topic=1734.0
https://newit.co.uk/forum/index.php?topic=353.0

(it would be interessting to know if the dreamplug has a similar power supply issue)
The OS was running on a pen drive.

I ordered a B3 to see if that one is better suited to run 24/7

  • but has also a much higher price..

Child Tickets

Change History (3)

comment:1 Changed 8 years ago by cypherpunks

Resolution: not a bug
Status: newclosed

comment:2 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:3 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.