Opened 8 years ago

Closed 5 years ago

#5731 closed defect (wontfix)

[CHROME] conflict with other extensions using WebRequest API (Ghostery, AdBlock Plus, etc)

Reported by: cerrese Owned by: pde
Priority: High Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords: conflict
Cc: battre@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tested HTTPS-Everywhere version:

https-everywhere-2012.5.1.crx ("may day" beta)
https-everywhere-2012.3.14.crx ("pi day" beta)

What's the problem:

Chrome shows extensions unable to work in following conditions:

1, Adblock Plus(with easylist, easyprivacy filter)+Https everywhere

The browser says Adblock plus is unable to change network request
when watching video in http://edition.cnn.com or using some google service(especially where google-analytics/google apis exists)

I guess both the extensions tried to change the connection using Webrequest API, resulting conflict with each other

2, Similar condition

HTTPS everywhere with Ghostery(3.0.0)

This time, it is HTTPS everywhere that cannot control the webrequest

Child Tickets

TicketStatusOwnerSummaryComponent
#5350closedpdeChrome HTTPS Everywhere conflict with Ghostery 3.0HTTPS Everywhere/EFF-HTTPS Everywhere

Attachments (1)

aaa.JPG (24.8 KB) - added by cerrese 8 years ago.
a sample showing adblock plus unable to work with HTTPS everywhere installed

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by cerrese

Attachment: aaa.JPG added

a sample showing adblock plus unable to work with HTTPS everywhere installed

comment:1 Changed 8 years ago by pde

Merging #5350 into this bug.

comment:2 Changed 8 years ago by pde

Summary: conflict with other Chrome extensions using WebRequest APIconflict with other Chrome extensions using WebRequest API (Ghostery, AdBlock Plus, etc)

comment:3 Changed 8 years ago by pde

Priority: normalmajor

comment:4 Changed 8 years ago by pde

Summary: conflict with other Chrome extensions using WebRequest API (Ghostery, AdBlock Plus, etc)[CHROME] conflict with other extensions using WebRequest API (Ghostery, AdBlock Plus, etc)

comment:5 Changed 8 years ago by battre

Cc: battre@… added

In principle the following conflicts can occur between these extensions:

1) Extensions try to redirect requests to different destinations.
2) Extensions try to perform incompatible header modifications.

@1: A common problem was that HTTPS everywhere redirected a request to an https URL, while an AdBlock implementation redirected a request to a data:// URL containing a transparent pixel or an empty document. I have changed the implementation such that data:// URLs are given precedence over other redirects to the network. They do not count as conflicts anymore. If two extensions redirect requests to different data:// URLs, this is still a conflict.

@2: There is a lot of logic in Chrome that prevents that identical header modifications are not flagged as conflicts. However, if two extensions try to set a header to a different value, or if one extension deletes a header and the other writes it, this is still considered a conflict.

I have tried to reproduce your issue but could not. This is how you can help debug the problem:

  • Start a recent version of chrome with a new profile directory: chrome --user-data-dir=/tmp/temp-profile On windows, this would be something like chrome --user-data-dir=c:\temp-profile
  • Install the extensions and adblock lists.
  • Restart chrome with chrome --user-data-dir=/tmp/temp-profile --log-net-log=/tmp/log.txt
  • Visit the minimal number of pages that trigger the conflict.

Attach log.txt to this bug or email it to me.

The first step (creating a new profile directory) is to preserve your privacy and make sure that we don't record any background traffic that contains personal information.

comment:6 Changed 7 years ago by beej

i guess new versions of Chrome give you more informative error messages. i just saw this in Chrome 25.0.1364.99 with HTTPS Everywhere 2013.1.18 and Privacyfix by Privacychoice 3.0.
---
This extension failed to redirect a network request to https://www.facebook.com/plugins/like.php?href=http://www.rlslog.net/xxxx/&layout=standard&show_faces=false&width=450&action=like&colorscheme=light&height=35 because another extension (Privacyfix by Privacychoice) redirected it to https://privacyfix.com/blank.html.
---

have you guys tested HTTPS Everywhere with Privacyfix? it seems like those two extensions would often be installed together.

comment:7 Changed 5 years ago by jsha

Resolution: wontfix
Status: newclosed

Currently videos on CNN.com don't play because of a problem with the Turner (partial) rule, not because of an interaction with ABP. I've been using ABP+HTTPSE for about a year and it seems very stable. Feel free to reopen with specific repro cases.

Note: See TracTickets for help on using tickets.