Opened 5 years ago

Closed 4 years ago

#5783 closed defect (user disappeared)

Timeout arg for launching tor broken on windows

Reported by: atagar Owned by: atagar
Priority: Low Milestone:
Component: Core Tor/Stem Version:
Severity: Keywords: controller
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Python's signal module lacks a 'SIGALRM' attribute on windows, causing the launch_tor function [1] to die with an AttributeError. We should look for an alternative for function timeouts that work on windows. Caught by pythonirc101.

[1] https://gitweb.torproject.org/stem.git/blob/HEAD:/stem/process.py#l16

Child Tickets

Change History (4)

comment:1 Changed 5 years ago by atagar

  • Resolution set to fixed
  • Status changed from new to closed

Working around this by disabling the timeout argument on Windows. Patches welcome if someone running Windows can come up with an alternative method for timeing out the function that works there!

https://gitweb.torproject.org/stem.git/commitdiff/688f321287f5e9c53451dd91608dc3aa5088a621

comment:2 Changed 5 years ago by atagar

  • Priority changed from normal to minor
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Summary changed from Tor launcher broken on windows to Timeout arg for launching tor broken on windows

On second thought I should use this ticket to track the fix for the timeout argument on Windows. The issue isn't really resolved until that is fixed.

comment:3 Changed 5 years ago by atagar

  • Keywords controller added

comment:4 Changed 4 years ago by atagar

  • Resolution set to user disappeared
  • Status changed from reopened to closed

Meh, this ticket is gonna be so old before we find someone that cares about windows that we might as well file a fresh one if this is still an issue then.

Note: See TracTickets for help on using tickets.