Opened 7 years ago

Closed 7 years ago

#5785 closed defect (fixed)

www.mail-archive.com https not working

Reported by: cypherpunks Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I get forwarded to https on www.mail-archive.com, but it doesn't seem to work. Seems their https setup is broken, maybe you should disable the rule.

Error message:

An error occurred during a connection to www.mail-archive.com.

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)

Child Tickets

Change History (5)

comment:1 Changed 7 years ago by Sebastian

Component: - Select a componentEFF-HTTPS Everywhere
Owner: set to pde

comment:2 Changed 7 years ago by pde

Resolution: invalid
Status: newclosed

Are you sure this is an HTTPS Everywhere bug?  Right now grep isn't showing me that we have a ruleset affecting this domain, either in the stable or development branches.

(Please reopen if it definitely is HTTPS Everywhere)

comment:3 Changed 7 years ago by hanno

Resolution: invalid
Status: closedreopened

Hi, just stepped over this again and it is still an issue (I created the original bug report). Opening mail-archive.com doesn't work, as I get forwarded to https, as soon as I disable https everywhere, it works again.

I'm using https everywhere on chromium.

I get the feeling that my https everywhere is not updating it's rulesets. Is there anything I need to do manually to do that? I don't find an option for it.

comment:4 Changed 7 years ago by pde

Weird. I still can't reproduce this or see a relevant ruleset in chrome version 2012.6.21. Is that the version you're running? Do you have any other chrome extensions installed?

comment:5 Changed 7 years ago by hanno

Resolution: fixed
Status: reopenedclosed

Whatever it was, I now managed to fix it by removing https everywhere completely and then reinstalling it. Seems something old was cached here.

Note: See TracTickets for help on using tickets.