Opened 8 years ago

Closed 4 years ago

#5842 closed defect (duplicate)

Expanded ORPort confuses arm

Reported by: atagar Owned by: atagar
Priority: Medium Milestone:
Component: Core Tor/Nyx Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Proposal 186 greatly expands the ORPort option, so it's no longer simply just a single port number (it might have addresses, multiple ports, special attributes, etc).

This change breaks arm's GETCONF calls to figure out the ORPort. We should figure out how arm wants to handle and display information about these new capabilities.

On tor's side, implementation for this was added in...
5f0a8dcd2cfcbafc3deb3a6717808b607a459dac

According to the man page this stuff doesn't yet seem to be documented which is pesky...
https://www.torproject.org/docs/tor-manual-dev.html

Issue caught by swalker.

Child Tickets

Change History (1)

comment:1 Changed 4 years ago by atagar

Resolution: duplicate
Severity: Normal
Status: newclosed

Duplicate of #4471.

Note: See TracTickets for help on using tickets.