Opened 7 years ago

Closed 7 years ago

#5897 closed defect (fixed)

Windows 8 Connection Error

Reported by: Jessica_XY Owned by:
Priority: Medium Milestone: Tor: 0.2.3.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: Windows 8 tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I am trying to use TOR at my school, which has a corporate firewall. Using tor on its own did not work, and gave me the following error:

"getsockname() to check for address change failed: Invalid argument [WSAEINVAL]"

I tried ticking the box "my firewall only lets me connect to certain ports", but the same error popped up.

Finally, I tried to use TOR bridges. The same error message popped up in the log. Tor stalled at "bootstrapped 90%".

Interestingly enough, TOR works perfectly at home. I have turned off Windows Firewall and my AV (at school) with no luck. 

I have a screenshot of trying to connect to TOR (through wifi) using public bridges, which I will try to upload.

Child Tickets

Attachments (1)

screenshot.png (144.7 KB) - added by Jessica_XY 7 years ago.
Error log on Windows 8, using bridges.

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by Jessica_XY

Attachment: screenshot.png added

Error log on Windows 8, using bridges.

comment:1 Changed 7 years ago by arma

Component: VidaliaTor Client
Milestone: Tor: 0.2.3.x-final
Priority: majornormal
Version: Vidalia: 0.2.17

The WSAEINVAL issue looks like a duplicate of #5374.

The bridge issue looks like a duplicate of #3443 (workaround: stop using bridges, or delete your cached-descriptors file).

comment:2 Changed 7 years ago by arma

Owner: chiiph deleted
Status: newassigned

comment:3 Changed 7 years ago by Jessica_XY

Ok, but the person in bug #5374 is a bridge, not a client. The problem is slightly different here. Unlike that user, I also can't open up a port in the corporate firewall or router. However, it is already set to "my firewall only allows me to use port 80 and 443", which are open on the corp. firewall.

comment:4 Changed 7 years ago by arma

Are you sure your Windows 8 firewall isn't preventing Tor from talking to itself?

comment:5 in reply to:  4 Changed 7 years ago by Jessica_XY

I have added the exceptions in the firewall for TOR and Vidiala, and have even tried turning off the firewall and antivirus without success. Also, TOR works fine at home (without the school's corp. firewall). I think its because the school is blocking some parts, despite me using bridges and only using connections for port 80 and 443.

comment:6 Changed 7 years ago by Jessica_XY

HELLO!!! Anyone like me... or know how to fix it????? o_O

comment:7 Changed 7 years ago by nickm

Keywords: tor-client added

comment:8 Changed 7 years ago by nickm

Component: Tor ClientTor

comment:9 Changed 7 years ago by Jessica_XY

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.