Opened 8 years ago

Closed 7 years ago

#5942 closed defect (invalid)

https everywhere makes firefox address bar unresponsive

Reported by: cypherpunks Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: gfa@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

after installing https everywhere extension addressbar becomes unresponsive, while typing an url it stops. in order to continue to write the url i have to click again on addressbar.

if i uninstall https everywhere the problem vanish, if i disable the extension problem continues.

i can repeat with an empty profile and/or beta version of https everywhere

i think the issue started on firefox 10, now i'm running firefox 12, platform is linux 32 bits

Child Tickets

Change History (8)

comment:1 Changed 8 years ago by pde

Hi.  What version of HTTPS Everywhere did you encounter this with?  Can you take a look with Live HTTP Headers to see if there are any requests going out while the addressbar is being laggy?

comment:2 Changed 8 years ago by cypherpunks

i found the issue with latest (2.0) and beta versions of HTTPS Everywhere.

but but i cannot reproduce the bug with a new firefox profile (this one would be the third)

let me use it a few more days before close this bug

thanks!

comment:3 Changed 8 years ago by pde

One cause to check for might be OCSP queries. You might observe this problem when (1) you have a profile with OCSP enabled, and (2) the OCSP responder is slow or down.

Because (2) would only happen some of the time, an OCSP performance bug would be a bit hard to reproduce reliably.

Another thing to rule out is Decentralized SSL Observatory queries. Those should never block the browser; it would be a bad bug if they did.

comment:4 Changed 8 years ago by pde

Another thing to rule out is other extensions that modify the address bar queries. If you had those, this could be a version of #3190.

comment:5 Changed 7 years ago by cypherpunks

i just disabled OCSP. i will keep using ff this way for a few days and report back

thanks

comment:6 in reply to:  5 Changed 7 years ago by cypherpunks

Replying to cypherpunks:

i just disabled OCSP. i will keep using ff this way for a few days and report back

thanks

on a separate note, SSL observatory was never enabled

comment:7 Changed 7 years ago by cypherpunks

i'm having the same problem using an empty firefox profile without https everywhere (or any other extension), so i've reported the bug to mozilla

feel free to close this bug report, sorry for the noise, took me a while to reproduce without https-everywhere

thanks!

comment:8 Changed 7 years ago by pde

Resolution: invalid
Status: newclosed

Excellent, thanks!

(HTTPS Everywhere would in fact exacerbate this problem, because more HTTPS means more OCSP queries to more flakey OCSP responders)

Note: See TracTickets for help on using tickets.