Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5946 closed defect (fixed)

tor 0.2.2.35 never connects

Reported by: phobos Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords: tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

A number of people have called over the past few days to state their tbb never connects and the onion always stays yellow. The problem is that tor is trying to reach a dir auth that doesn't exist at the IP in the source code anymore.

I believe we know this because some of the dir auths changed IP addresses over the past few months. However, I couldn't find a ticket for it.

Child Tickets

Change History (7)

comment:1 Changed 8 years ago by Sebastian

It's true that it's known. We don't have a ticket because technically, it is fixed - there just hasn't been a tor release.

comment:2 Changed 8 years ago by arma

We don't have a release because we don't know if a release would work. Our process is stuck.

Maybe I should just tag and sign a tarball anyway?

Erinn tested a test tarball briefly and said it seemed to work.

comment:3 Changed 8 years ago by mikeperry

I think the root problem is that vague ticket is vague. If the problem really is dirauth IP change, isn't the fix obvious and simple? Or are we not yet sure the other changes in 0.2.2.36 are safe?

Also, is there a subset of clients that this affects? This seems very strange. I have no problems. Why are some dirauths blocked in some places and not others?

comment:4 Changed 8 years ago by mikeperry

Or alternatively: yeah. Just tag the mofo and push it. What could possibly go wrong? ;)

comment:5 Changed 8 years ago by arma

Resolution: fixed
Status: newclosed

I tagged and pushed it.

That said, there's a good chance the "never connects" users are experiencing #3443 (not solved in 0.2.2.36), rather than the authority address switch.

Closing because the specified bug, even if it's not really the bug the users were experiencing, is fixed now.

comment:6 Changed 8 years ago by nickm

Keywords: tor-client added

comment:7 Changed 8 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.