Opened 7 years ago

Closed 6 years ago

#6035 closed defect (duplicate)

Empty 'Tools->HTTPS Everywhere' menu in Firefox

Reported by: cypherpunks Owned by: pde
Priority: Low Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: EisahLee@… Actual Points:
Parent ID: #6276 Points:
Reviewer: Sponsor:

Description

Steps to reproduce with a clear profile:

  1. Start Firefox.
  2. Install HTTPS Everywhere and restart the browser as requested.
  3. Remove HTTPS Everywhere icon from the browser's Navigation Toolbar (using the Customize feature).
  4. Restart Firefox.
  5. Expand the 'Tools' menu and try to see the content of the 'HTTPS Everywhere' menu item.

The menu item is empty and this error is logged:

Timestamp: 06/02/2012 02:21:32 PM
Error: TypeError: popup is null
Source File: chrome://https-everywhere/content/toolbar_button.js
Line: 45

Returning the toolbar icon back and restarting Firefox fixes the menu.

Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/15.0 Firefox/15.0a1

Child Tickets

Change History (5)

comment:1 Changed 7 years ago by pde

Resolution: duplicate
Status: newclosed

This is a duplicate of bug #5893.

comment:2 Changed 6 years ago by eisahlee

Cc: EisahLee@… added
Resolution: duplicate
Status: closedreopened

Not exactly a duplicate, as this error still occurs, both in 3.4.2 and 1331099bd1d7cad8a68bba30fcc259f0e541e4ab (basically 4.0development13).

I'm willing to test any fix you propose.

With regards,
Eisah

comment:3 Changed 6 years ago by pde

This is caused by the user dragging the HTTPS Everywhere icon out of the toolbar using View->Toolbars->Customize.

There may be a workaround, which is to leave HTTPSE in the menu bar or the addons bar rather than deleting its button (ie, leaving it in the tray of unused buttons) altogether.

I started work on a true fix for this recently but it's quite obscure and intricate XUL hacking :(

comment:4 Changed 6 years ago by pde

Priority: normalminor

I started work on this bug in the toolbarbuttonless branch of my remote. But this is not a high priority because it affects so few users and could certainly use some help from people who care about it.

comment:5 Changed 6 years ago by pde

Parent ID: #6276
Resolution: duplicate
Status: reopenedclosed

This is a duplicate of #6276 which describes the problem more clearly.

Note: See TracTickets for help on using tickets.