Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6047 closed defect (not a bug)

Possibly erroneous Vidalia warning re: socks4 when using socks4A.. 4A!

Reported by: TheDude Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Keywords: socks4a tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This is a little bug that bugs me and I feel like I may as well share it here. ( Just to give a little context I'm not using in Tor in a sort of will-be-thrown-into-a-Chinese-jail-if-one-bit-of-identity-leaks-somewhere situation, its just something I use for curiosity and what may or may not be the 'reasonable' or 'moderate anonymity' it offers... sometimes...)

Okay - anyway - I use proxifier to route individual applications through tor. Now I'm no expert but I have done a bit of reading here and elsewhere and have at least bothered to do the following:

Check the SOCKS 4A setting in Proxifier, which is a specific setting it has
Monitor incomings and outgoings with Little Snitch
Run dnscrypt to further mitigate/stop any possible DNS leaks

Yet in the Advanced section of the Vidalia client in the message log it continually responds with:

"Warning - Your application (using socks4 to port xxx) is giving Tor only an IP address. Applications that do DNS resolves themselves may leak information..."

But I am using Socks 4A! Not merely 4, 4a. So either Proxifier is just lame and wrong or Vidalia/Tor is wrong. If former is true then I guess its a bug and an annoying one at that and could the message be removed.

I have a few other issues I want to raise but I guess I'll need to raise separate tickets.. apologies if I'm writing this in the wrong way and I've tried raising issues via email and was not content with response trying to do it that way...

Child Tickets

Change History (8)

comment:1 in reply to:  description Changed 7 years ago by arma

Replying to TheDude:

"Warning - Your application (using socks4 to port xxx) is giving Tor only an IP address. Applications that do DNS resolves themselves may leak information..."

But I am using Socks 4A! Not merely 4, 4a.

Tor only prints that if you're using 4 or the wrong kind of 5. It doesn't (or at least shouldn't) print it when you use 4a.

Are you super double extra sure you're using 4a?

comment:2 Changed 7 years ago by arma

Component: VidaliaTor Client
Owner: chiiph deleted
Status: newassigned
Version: Vidalia: 0.2.17

comment:3 Changed 7 years ago by TheDude

How would one make sure though?

In Proxifier, the version I have, into proxy settings it says:

Server
Address: 127.0.0.1 Port: 9050

Protocol
SOCKS Version 4

But below this:

Settings
Use SOCKS 4A extension (remote hostname resolving feature) - this box is checked

I don't know how to check that it is on 4A beyond trusting the application's checkbox here...

comment:4 in reply to:  3 Changed 7 years ago by TheDude

Also if it isn't too much trouble could you comment on how dnscrypt plays a role in stopping dns leaks, would you say it completely stops leaks or is useless or... what is your view of it for this tool, thanks

comment:5 Changed 7 years ago by nickm

Milestone: Tor: unspecified

comment:6 Changed 7 years ago by arma

Resolution: not a bug
Status: assignedclosed

I think this ticket might be not-a-bug (or at least, not-a-bug-in-Tor). I assume the application in question is using the type of handshake that Tor says it is.

As for dnscrypt, never heard of it. Maybe you should try asking on irc or the tor-talk mailing list.

comment:7 Changed 7 years ago by nickm

Keywords: tor-client added

comment:8 Changed 7 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.