Opened 7 years ago

Closed 14 months ago

#6048 closed defect (wontfix)

"Authenticating to Tor" stage permanently

Reported by: TheDude Owned by: chiiph
Priority: Medium Milestone:
Component: Archived/Vidalia Version: Vidalia: 0.2.17
Severity: Normal Keywords: Authenticating, archived-closed-2018-07-04
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I looked up this issue (yes, I did try) and the remedy you seem to suggest is to check if other versions of Vidalia or Tor are running - I have no other versions running and I do not have the authentication setting turned on in the preferences and yet it just stays on "Authenticating to Tor" no matter what. It will also ask for a password on startup. Now what I do in practice is just cancel this and ignore the "Authenticating to Tor" (as it connects and bootstraps anyway) but it seems shoddy and a bug that the GUI continues to state "Authenticating..."

Child Tickets

Change History (5)

comment:1 Changed 7 years ago by arma

Sounds like #4827. Which was supposed to be fixed in Vidalia 0.2.16.

What do you mean by "it will also ask for a password on startup"? Please walk us through exactly what you do, what Vidalia does, what you expected, etc.

comment:2 Changed 7 years ago by TheDude

Sure.

Well - every time I turn Vidalia on (this is what I mean by startup, open the Application), it asks for the authentication password. The little dialog box comes up asking for it. Which I cancel to make go away. [If I toggle Tor, i.e. turn off and on (so I can get Google unblocked again or something), the pw box comes up again and I can cancel the box to make it go away or just ignore it.]

I don't expect it to keep doing this because a) I don't have that authentication setting turned on in the preferences that should logically be the cause of it and b) none of the things apply that should cause it from what I can remember from reading your FAQs on this issue to do with running other versions of Tor or any of the other components and obviously c) it works just the same, so clearly this auth step not required!

One thing I do remember possibly not being a coincidence is this problem started ever since I accidentally turned on authentication in the prefs one time. My finger must've just slipped once or something. And ever since then, having unchecked this box and kept it that way ever since, it has always asked for a password that it doesn't seem to need to actually function and I never get the green Tor symbol... even though as I say it just works anyway same as before... seemingly... just seems wrong that it should work and yet have this amber indicator stating it is not working...

comment:3 Changed 7 years ago by chiiph

Could you paste in here your vidalia.conf and torrc?

comment:4 Changed 21 months ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

comment:5 Changed 14 months ago by teor

Keywords: archived-closed-2018-07-04 added
Resolution: wontfix
Status: newclosed

Close all tickets in archived components

Note: See TracTickets for help on using tickets.