Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#6054 closed defect (duplicate)

https-everywhere prevents disqus threads from loading even when disabled

Reported by: KIAaze Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: #5496 Points:
Reviewer: Sponsor:

Description

Hi,

I noticed that comments on http://www.omgubuntu.co.uk, powered by disqus stopped loading when using HTTPS everywhere.
Disqus comments load correctly when the plugin is disabled via firefox add-on manager or when the disqus filter is disabled in HTTPS everywhere, but not when it is disabled via the plugin menu "Disable HTTPS everywhere".
"Disable HTTPS everywhere" should logically disable all filters.

Tested with a clean profile on Firefox 12.0 and HTTPS-everywhere v2.0.5 on Ubuntu 11.10.

Child Tickets

Change History (3)

comment:1 Changed 8 years ago by confluence

I am also experiencing this problem. It doesn't happen on all sites that use Disqus. It happens on all pages of the South African Mail & Guardian -- for example: http://mg.co.za/article/2012-06-14-radio-stations-face-r1bn-royalties-bill

(I'm more concerned about Disqus not working on some sites than I am about the global disabling of filters not working as expected.)

comment:2 Changed 8 years ago by pde

Parent ID: #5496
Resolution: duplicate
Status: newclosed

This is going to be fixed shortly by disabling the Disqus ruleset.

comment:3 Changed 8 years ago by pde

Oh, I guess I should add that this could be a separate bug anyway if it is really happening when HTTPS Everywhere is disabled. I haven't been able to reproduce that, however...

Note: See TracTickets for help on using tickets.